I upgraded from Ubuntu 10.04 to 12.04 and it went fine. After restart, when I try to log in from my root user it shows a command screen in a split second and then returns back to the log in screen which shows all users. I have even tried to test logging in with other users and it is working fine.

I guess there is some problem with home folder of my user or something. Kindly help me out otherwise my only hope is to make a fresh install from a CD which I am avoiding.

Thanks in advance.

  • When you say root user, do you mean the following account: root@your-hostname? Or an account that is part of sudoers (i.e., accounts that can't execute sudo)? – oaskamay Mar 14 '13 at 15:20

This solution originally by actionparsnip worked for me:


Log in with you user name and password

Run the following command: sudo chown -R $USER:$USER $HOME

Try to log in
  • 1
    Recursively changing file user/group ownership should be done with very much care. Please don't suggest this out of nowhere. – gertvdijk Aug 14 '14 at 15:00
  • why don't you also tell what are the consequences of doing this? And give the solution to this problem instead of preaching. – user1595633 Aug 14 '14 at 15:17
  • The answer is correct. It can be made clear --only /home/<user>/.Xauthority files needs to be chowned. – Jayan Aug 21 '14 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.