It has been a long time since I've asked for help, but I'm in dire need now.

Some time ago, I set up a friend's computer with 10.04. He's still running it but somewhere along the way, he started having trouble with his nvidia drivers and seemingly his whole system. Remotely, I've been trying to help him start from scratch and install fresh with 12.10. The problem is that his CD-rom is broken, and his BIOS will not allow him to boot from external media, i.e., usb cd/dvd rom and/or usb flash drives. Space on his system partition was very low but has deleted enough to give him just over a gig. I thought the best solution would be to boot from a local iso file through grub2. However, his system hasn't been updated/upgraded to grub2, he is still using the legacy version. We can't seem to upgrade him because, well, I guess you could say apt-get is (broken?) and apt-get -f install isn't fixing it. We can't remove or add packages until this is resolved. I've listed the commands we've tried and their output.

I would appreciate any help that would allow us to update the computer to grub2 and/or do a fresh install of Ubuntu.

sudo apt-get -f install

dpkg: error processing /var/cache/apt/archives/linux-headers-2.6.32-45_2.6.32-45.104_all.deb (--unpack):
unable to create `/usr/src/linux-headers-2.6.32-45/drivers/cpufreq/Kconfig.dpkg-new' (while processing `./usr/src/linux-headers-2.6.32-45/drivers/cpufreq/Kconfig'): No space left on device
No apport report written because the error message indicates a disk full error
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:

sudo dpkg --configure -a

dpkg: dependency problems prevent configuration of linux-headers-2.6.32-45-generic:
linux-headers-2.6.32-45-generic depends on linux-headers-2.6.32-45; however:
Package linux-headers-2.6.32-45 is not installed.
dpkg: error processing linux-headers-2.6.32-45-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-2.6.32-45-generic; however:
Package linux-headers-2.6.32-45-generic is not configured yet.
dpkg: error processing linux-headers-generic (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/linux-headers-2.6.32-45_2.6.32-45.104_all.deb

dpkg: error processing /var/cache/apt/archives/linux-headers-2.6.32-45_2.6.32-45.104_all.deb (--install):
unable to create `/usr/src/linux-headers-2.6.32-45/drivers/cpufreq/Kconfig.dpkg-new' (while processing `./usr/src/linux-headers-2.6.32-45/drivers/cpufreq/Kconfig'): No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:

sudo apt-get autoremove

You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
linux-headers-2.6.32-45-generic: Depends: linux-headers-2.6.32-45 but it is not installed
E: Unmet dependencies. Try using -f.
  • Have you tried fixing the broken packages with Synaptic Packet Manager? Have you done sudo apt-get update, sudo apt-get upgrade and sudo apt-get dist-upgrade? An apt-get autoclean might help, too.
    – David
    Mar 14, 2013 at 7:22
  • Yes, we've tried upgrading and updating. However, both of those give output to the effect that we need to first fix the broken packages. Essentially, we don't know how to fix it. Autoclean was done and free up some space. Mar 14, 2013 at 19:36
  • To Warren -- Thanks for the link, but that seems applicable to having an existing windows install. I only wish we had that so that we could update the BIOS and allow external media booting. It does give me more ideas -- is there any way to install another Ubuntu system (12.10) to another partition from the existing Ubuntu system (10.04)? Mar 14, 2013 at 19:58

1 Answer 1


Have you tried to remove old unused kernel versions ? First list current active kernel with uname -r, next list all installed kernel using dpkg --list 'linux-image*' and finaly remove all kernel except the current with apt-get remove linux-image-x.x.x-xx-generic. It work perfectly for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.