20

My system default is Nautilus. But when I right-click in Downloads and choose "open containing folder", it opens Thunar and not Nautilus.

Open containing folder

How can I change that?

10 Answers 10

17

After a lot of tries, I came upon the very simple method given above by Gill Bates, which was to

  1. Go into System Settings
  2. Switch default manager to something else
  3. Switch it back

So I did that, then closed and reopened Firefox and sure enough, it worked like a charm. Maybe I can invoke Occam's Razor here...

  • 1
    this worked for me. i did not have to restart firefox. – Jayen May 12 '14 at 22:18
  • 2
    Identical issue in Kubuntu 14.04, this fixed it. In KDE it's Default Applications -> File Manager. – Ash May 28 '14 at 5:05
  • Thankyou! I can't believe this worked... As per Ash's comment this fix works on Kubuntu trusty – dwurf Sep 4 '14 at 0:59
  • 3
    Could you add a hint on where in System Settings that change can be made? In Ubuntu 16.10, there is a section named Default Applications in the Details settings, but it only lets me select defaults for Web, Mail, Calendar, Music, Video, and Photos, no file manager. – O. R. Mapper Dec 7 '16 at 9:40
  • The solution is the result of the file manager becoming the first mentioned after inode/directory=, in /usr/share/applications/mimeinfo.cache after the setting for file manager is refreshed as indicated (see my answer). Your solution is possible in Unity and other desktops where one has that setting to switch the file manager with a GUI. When that is absent, it can be done manually as indicated. – user47206 Jan 11 '17 at 23:25
7

The suggestion by @carnendil is not wise because the system generates this list at startup and it therefore should not be directly edited by the user. In fact, each entry is supposed to contain all the options available on the system and sometimes the first entry is not the preferred one.

In theory, the suggestion by @Fab should work, but it turns out that sometimes programs attempt to reference defaults.list exclusively. For example, the discussion on Bugzilla reveals that Firefox doesn't even know to look for either of the user's local lists, defaults.list and mimeapps.list.


Therefore, I suggest you edit one of the following files, with the first option probably being the wisest choice unless you are on a multiuser system:

  1. Edit /usr/share/applications/defaults.list; or
  2. Edit both ~/.local/share/applications/mimeapps.list and ~/.local/share/applications/defaults.list; or
  3. Edit one of the files within ~/.local/share/applications/ and then create a symbolic link to that file from the other (e.g. edit ~/.local/share/applications/mimeapps.list and link to it from ~/.local/share/applications/defaults.list).

To one of the following options above, add (or change) the following line:

inode/directory=Thunar-folder-handler.desktop
  • 1
    The accepted answer did not work for me, but this worked for me in Xubuntu 16.04 LTS for Thunar File Manager; Only editing point 1: inode/directory=thunar.desktop (the other files don't exists). – Rutrus Mar 4 '17 at 14:19
  • 1
    I think using xdf-mime default thunar.desktop inode/directory is even more robust. – Raphael Nov 16 '17 at 7:23
5

I also encountered such problem, but in my case - just switching default File Manager to something and back to needed one, using standard gui, was helpful.

  • The solution is the result of the file manager becoming the first mentioned after inode/directory=, in /usr/share/applications/mimeinfo.cache after the setting for file manager is refreshed as indicated (see my answer). Your solution is possible in Unity and other desktops where one has that setting to switch the file manager with a GUI. When that is absent, it can be done manually as indicated. – user47206 Jan 11 '17 at 23:25
3

There is an old bug that points to some setting in the file /usr/share/applications/mimeinfo.cache.

The line that starts with inode/directory= in my system looks like this:

inode/directory=nautilus-folder-handler.desktop;nautilus.desktop;

I guess yours points to Thunar instead.

To make the change, you need to edit mimeinfo.cache with:

gksu gedit /usr/share/applications/mimeinfo.cache
  • 2
    The KDE equivalent to that last line would be to Alt-F2 to get a run dialog and then kdesudo kate /usr/share/applications/mimeinfo.cache. – pbhj Jul 21 '15 at 22:44
3

If the already mentioned solutions don't work, try this.

Write the following to /usr/share/dbus-1/services/org.freedesktop.FileManager1.service:

[D-BUS Service]
Name=org.freedesktop.FileManager1
Exec=/usr/bin/thunar --gapplication-service

Change the Exec line to your liking. (Default nautilus.)

2

If you don't want to modify the system settings, or don't have access to it, you may copy & personalize the line starting with inode/directory= (from /usr/share/applications/mimeinfo.cache) to ~/.local/share/applications/mimeapps.list

1

Solution for those running an XFCE environment, based on the other answers:

  1. Run xfce4-mime-settings (or Settings Menu -> Mime Type Editor).

  2. Find inode/directory in the list

  3. Set Open Folder with Thunar or similar

0

had the same problem (Kubuntu 14.04, download-folder are opened with audacious). Ultimative solution explained here: https://mtekk.us/archives/guides/make-firefox-use-dolphin-for-open-containing-folder/ In my case: I had to remove audacious and gwenview from the list and it worked (opens with my default file-manager dolphin)

0

The solution presented in other answers here and here involving refreshing the setting for file manager also works, but you need the GUI setting for that, and it also may be temporary, as the culprit may take over after programs installations or updates (see link below).


This is a problem that also appeared for me in more recent Ubuntu versions and ubuntu-based systems, and also in other Linux systems like Manjaro. It also appears in the same way in other browsers like Chrome and even other programs (like uGet, a downloader that also has the option "open containing folder"). The problem may appear also in more severe forms, where the default file manager is not replaced by other file manager, but by a different program (text editor, multimedia player).

The problem is, as indicated here, triggered only by the certain programs.

The best solution is to create or edit ~/.local/share/applications/mimeapps.list: edit the line that starts with inode/directory= and add the name of the file manager that you use if it is not there already; if that is already there but another program is listed there first, put the file manager first (if you need the other program(s) to open folders).

For Pantheon Files it should be like

[Default Applications]
inode/directory=nautilus-folder-handler.desktop

If the desktop environment is not freedesktop complient, like my Manjaro Cinnamon, the file to be created/edited should be ~/.local/share/applications/mimeinfo.cache like so:

[MIME Cache]
inode/directory=nautilus-folder-handler.desktop

Also here.

0

I had the same issue as you guys but none of the answers really worked for me.

I had downloaded Konqueror (so that I can listen to Spotify independently of Firefox) and it had installed Dolphin as a prerequisite. Firefox started opening files in Dolphin after that.

As I do not use Dolphin for anything and Konqueror is only being used for Spotify, I decided to do away with Dolphin. Every distro has some kind of option to uninstall packages while leaving the packages that depend on them alone.

In arch it was:

sudo pacman -Rdd dolphin

I don't use Ubuntu but since this channel is called askubuntu, I did a bit of research for the Ubuntu equivalent:

sudo dpkg -r --force-depends dolphin

(based on this thread)

For Thunar it should be:

sudo dpkg -r --force-depends thunar

Obviously this won't apply to everyone. It's a judgment call, you have to be sure that the extra filebrowser you're removing is not essential to something that will break without it. As long you're certain no system apps need it, you can always uninstall it and see if things are stable and just re-install it if they are not.

  • you have installed the culprit without needing it, and removing it is of course a solution. but if the problem is created by a program that you want to keep, look here. – user47206 Jan 13 '17 at 11:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.