I'm getting the message: "The system is running in low graphics mode. Your screen, graphics card and input device settings could not be detected correctly. You will need to configure these yourself." ...

... but only during shutdown.

It doesn't impact use in any way, but it's confusing to people who see it while the machine is shutting down.

The system is NOT running in low graphics mode - it's working perfectly and at the correct (high) resolution.

How can I prevent this message from showing for 5 seconds every single time I reboot or shut down? The message ONLY appears during shutdown.

Graphics: i915.

Yes, I have a SSD. I've already put the sleep 2 in my /etc/init/lightdm.conf.

  • i had once this error ..what i did is power off the my laptop from power button ... – Qasim May 16 '13 at 17:52
  • Possible Duplicate: askubuntu.com/q/141606/21195 – Rodrigo Martins May 20 '13 at 2:00
  • Have you looked at this Q&A? askubuntu.com/q/141606/21195 – Rodrigo Martins May 20 '13 at 2:01
  • @RodrigoMartins Yes. As I noted in my question, this happens only at shutdown and does not affect the use of the system. The system is running just fine, NOT in low graphics mode. None of the existing questions appear to address this failure mode. – dmd May 20 '13 at 12:55
  • Although the problem of the user that made that question was on boot, have you tried the solutions given? Like to reinstall package ubuntu-desktop and the other ones? – Rodrigo Martins May 20 '13 at 13:00

Your problem seems to stand at LightDM, so probably you can fix that by these steps:

sudo apt-get update
sudo apt-get upgrade
sudo dpkg-reconfigure unity-greeter
sudo dpkg-reconfigure lightdm

Select "lightdm" and test it, if it didn't solve the problem try running the last command again and choosing a different option (if there is one).

If you is still having trouble try:

sudo gedit /etc/lightdm/lightdm.conf

and replace the following line:




If it not be effective replace back the line to its previous state.

  • It was already unity-greeter, so no need to change that. Doing the dpkg-reconfigure stuff did nothing. – dmd May 23 '13 at 17:49
  • @dmd Well, I am sorry, I can't help you further more than this, it is all I know, but if you are really, really, really annoyed by this, you can always make a clear install over again. But I think this is not the case... – Rodrigo Martins May 23 '13 at 23:24
  • This actually happens on every install. I've installed using a preseed file on dozens of (identical hardware) machines - this is for a commercial product. So, I guess it's something to do with the motherboard/integrated intel i915 graphics. Oh well. We'll just have to tell the customer to ignore it... – dmd May 24 '13 at 13:39

I face the same error. At that time you just need to go into tty mode and and login with user id and password. After that run the following command.

sudo apt-get dselect-upgrade

It will solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.