9

I've googled quite a bit but nothing I've found works. I just want to display the Trash, Home folder, Computer etc icons on my Desktop in Ubuntu.

The closest I've come is installing dconf-tools, running it, going to org -> gnome -> desktop -> background and checking show-desktop-icons then org -> gnome -> nautilus -> desktop and checking the icons I want to show.

Nothing happens.

I've also tried looking in compizconfig-settings-manager and gconf-editor but can't find anything there.

Ideas?

  • For me, it was in System settings => Desktop, there are some desktop icon switchers :) – jave.web Sep 17 at 10:04
16

You can enable them using Unsettings:

Unsettings "Desktop" tab

Or you can use the command line:

gsettings set org.gnome.nautilus.desktop home-icon-visible true
gsettings set org.gnome.nautilus.desktop computer-icon-visible true
gsettings set org.gnome.nautilus.desktop trash-icon-visible true
gsettings set org.gnome.nautilus.desktop network-icon-visible true
| improve this answer | |
  • Perfect. I couldn't find Unsettings (well, sudo apt-get install unsettings didn't work) but the command line commands did work. I gotta ask - those commands look remarkably similar to the changes I made using dconf-tools (the paths are identical) - how come it didn't work from there? Thanks again – powerbuoy Mar 13 '13 at 13:07
10

Story behind

I don't have any of those icons in my desktop, so I just checked the options that you mentioned and this were already activated!

So, maybe there is a problem with dconf, well I don't know, but these configurations doesn't make any change in my system (Ubuntu 12.10).

The answer

  1. Install Ubuntu Tweak Install-It

  2. Click in the Tweaks label and then in the Desktop Icons icon (sounds recursive :) )

    SS_1

  3. Finally you should see a window similar than the following allowing you to show/hide the icons.

    SS_2

This is my result. It works even when donf have different values.

| improve this answer | |
0

On Lubuntu, you can enable or disable the Trash and Home folder desktop icons by running xfdesktop-settings and clicking on the "Icons" tab.

| improve this answer | |
0

Install the Tweaks with sudo apt install gnome-tweaks

Then, open Tweaks and go to the desktop tab and uncheck whatever you do not want on your desktop.

Gnome Tweak Tool

| improve this answer | |
0

If using nautilus (default file manager in Ubuntu) OR nemo (a much better file manager in my opinion), see my answer here for info on how to do it for both cases: How to set Nemo as the default file manager in Ubuntu 18.04?.

In short, for nemo use dconf-editor and for nautilus use gnome-tweak-tool. Again, refer to the link above for screenshots and details.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.