43

I installed Teamviewer to help a friend (Afterwards I forcibly moved him to using Google Hangout) and noticed that it loads automatically a process even if I am not running teamviewer:

enter image description here

It does not show in the Startup Applications so I am guessing it is either hidden in the Startup applications or it is loaded by an option in a configuration file. I want to remove this automatic way of loading into memory so that it only works when I actually use teamviewer and not every time I boot the computer.

79

If you mean teamviewer 8 try sudo teamviewer --daemon disable (disable teamviewer 8 autostart)

| improve this answer | |
  • 2
    Nice one. That puppy will not be auto starting any time soon. – Luis Alvarado Mar 12 '13 at 17:02
  • 2
    Yeah annoying, since tv8, tv7 was not auto-starting. – user139737 Mar 12 '13 at 17:03
  • I got an error that I don't own some files, so I did it without sudo again, but it worked anyway – rubo77 Feb 18 '15 at 16:50
3

I've had this problem just now, and solved it by changing the option "[int32] Always_Online" to "0" in the file /etc/teamviewer/global.conf. Basically, what you should is to access this file with sudo privileges, and change this line:

[int32] Always_Online = 1

For this one:

[int32] Always_Online = 0

Best regards! :)

| improve this answer | |
  • 2
    Can't find this line. I'm on Ubuntu 14.04 (latest updates), TV version 11.0.67687 – johann_ka Jan 6 '17 at 19:31
0

Well, I can't find any autostart .desktop on the deb file, so it should either create it after someone launches the application or is auto-started by Wine(?).

Check both /etc/xdg/autostart/ and ~/.config/autostart/ for a .desktop file which could be launching either Teamviewer of Wine. If you find any you can remove it or change any of those values:

X-GNOME-Autostart-enabled=false # disables autostart
Hidden=false                    # shows item on Startup Applications
| improve this answer | |
  • it is not started from a .desktop file, but via /etc/init/teamviewerd.conf which can be configured like the other answer says. – törzsmókus Apr 7 '16 at 9:44
0

May be this resource could help you.

https://community.teamviewer.com/t5/TeamViewer-General/How-to-disable-teamviewerd-on-Debian/td-p/2088

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.