I am trying to start a VM using VirtualBox, however I get the following errors.

VB error 1

VB error 2

I have read many pages on this error (some on this forum) but none of the suggested fixes I have found seem to work. During install, whether using apt-get or a downloaded .deb I get install errors.

Terminal - install errors

I have tried installing VirtualBox 4.1 and 4.2 with the same results. Some suggestions I read sat to update the headers, where I get more errors.

Terminal - header errors

I must have some component or other missing from my system that VirtualBox does not like and dependencies that are not getting resolved :(

Are there any other suggestions?

  • Just so you know I've played with virtualBox a lot and found it just had too many issues. Doesn't even support 3D cards in any useful way. VMWare is far superior and I run my 3D steam games with no issues. Not an answer, but a recommend. – Meer Borg Mar 12 '13 at 14:56
  • 1
    Due to bug #1081307 the virtualbox-ose package won't build its kernel modules in 12.04, or 12.10. Try to install the most recent version from the Oracle repository: askubuntu.com/questions/41478/…. – Takkat Mar 12 '13 at 15:33
  • @Takkat - read the page you linked to. Still not fixed :( Looked at the install log and it contains the following: Attempting to install using DKMS Creating symlink /var/lib/dkms/vboxhost/4.2.8/source -> /usr/src/vboxhost-4.2.8 DKMS: add completed. Failed to install using DKMS, attempting to install without Makefile:181: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop. As shown above I'm having a lot of problems with my Kernel headers. – Andrew Mar 13 '13 at 13:48

I gave up trying to get Virtualbox to work so I installed VMware. However after installing and running apt-get update and apt-get upgrade, VMware didn’t work :( But when I opened Virtualbox again, it did! So it worked out the fix for Virtualbox was to install VMware. It must have installed a dependency I needed. At least it works now!


After Virtualbox stopped working again, I found a more permanent fix on Super User. The below commands install the latest headers. The last one updates Virtualbox with the new information.

sudo apt-get update

apt-cache search linux-headers-$(uname -r)

sudo apt-get install linux-headers-$(uname -r)

sudo ./etc/init.d/vboxdrv setup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.