I have a new TM2792S monitor/tv. It does not look good in 1920x1080, the Unity menu is barely visible and also the top panel. So it looks like it overscans.

My xorg.conf is only configured to use nvidia as driver, nothing else.

This is my Xorg.0.log: http://paste.ubuntu.com/5606146/

There are alot of rows like this:

[ 14466.180] (WW) NVIDIA(GPU-0): The EDID for LG Electronics TM2792 (DFP-1) contradicts itself: [ 14466.181] (WW) NVIDIA(GPU-0): mode "1920x1080" is specified in the EDID; however, the [ 14466.181] (WW) NVIDIA(GPU-0): EDID's valid VertRefresh range (58.000-62.000 Hz) would [ 14466.181] (WW) NVIDIA(GPU-0): exclude this mode's VertRefresh (50.0 Hz); ignoring [ 14466.181] (WW) NVIDIA(GPU-0): VertRefresh check for mode "1920x1080".

xrandr gives this output:

$ xrandr Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192 DVI-I-0 disconnected (normal left inverted right x axis y axis) VGA-0 disconnected (normal left inverted right x axis y axis) DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 337mm 1920x1080 60.0*+ 60.0 59.9 50.0 30.0 25.0 24.0 30.0 30.0 25.0
1360x768 60.0
1280x1024 60.0
1280x720 60.0 59.9 50.0
1152x864 60.0
1024x768 60.0
800x600 60.3
720x576 50.0 25.0
720x480 59.9
640x480 60.0 59.9 59.9

I found this command to make it look better: nvidia-settings --assign CurrentMetaMode="DFP-1: 1920x1080 { ViewPortOut=1850x1045+40+20, ViewPortIn=1920x1080 }"

But, with this you still see that the resolution is somehow wrong, it's not 1:1 pixel-mapped AFAIK.

  • Changed mode on the monitor to "Just scan" instead of "16:9". Now I don't need that ViewPortX-change but it still looks really bad. – Konstigt Mar 11 '13 at 22:32
  • I tried connecting my TV up PC with HDMI it looked terrible! When I switched to an old RGB cable the quality was way better. I've never seen a TV look as good as a monitor yet! – Matt H Mar 12 '13 at 0:26

Changing the monitor/tv to "Just scan" + installing Ubuntu tweak to enable changing of fonts hinting & antialiasing did some good. Then I also switched picture mode on the monitor/tv to Game instead of Standard. Now even better.

So now it's maybe as good as it will get.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.