3

In Nautilus I can connect to Windows shares using 'Connect to', but I can't browse to them in the network area. They don't show up. My Linux samba shares show up, but not the windows machines.

What's the reason and how can I fix that?

5
  • What is your question? (remember, this site is about Questions & Answers)
    – guntbert
    Mar 11 '13 at 21:03
  • Question: What's the reason and how can I fix that?
    – NilsB
    Mar 12 '13 at 4:55
  • Have the same problem. My opinion this is a bug in smbclient or dbus. Shattle with developers failed)) ...in thousandth time. Shares on ubuntu 12.10 work correct through command like this mount -t cifs //IP/share -o user=user%password,uid=your_uid Try it. Ubuntu 12.10 has many others bugs. I don't recommend to use it
    – seeline
    Mar 12 '13 at 13:02
  • The humour is that i work in kdenlive sometimes but kdenlive doesn't work in ubuntu 12.04(unresolved bug with too often crashes). Crazy ubuntu)))
    – seeline
    Mar 12 '13 at 13:19
  • mount -t cifs //IP/share /mount/point -o user=user%password,uid=your_uid
    – seeline
    Mar 12 '13 at 13:24
0

None of the computers in your network is configured to use lan manager announcement.

This is where one computer on the network enumerates all available shares and then broadcasts them for other Samba clients to read.

It is fine to have more than one computer do it but if none of them are configured to do it you can't browse shares.

There's an article here that describes Samba options:

http://www.onlamp.com/pub/a/onlamp/excerpt/samba_chap7/index2.html?page=3

Alternatively, you can configure the Windows Share protocol on one of your Windows computers to enable Lan Manager protocol.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.