10

I just installed KDE and put the taskbar vertically on one of my 2 monitors. The problem is that maximized windows don't recognize the taskbar space. The maximized windows go under the taskbar.

It works fine if I use only one monitor or set the 2nd monitor as a clone. It then works as expected, that is when I maximize a window it goes up to the edge of the taskbar. How can I make it work like this using dual monitors?

  • One more related bug-report at KDE tracker: bugs.kde.org/show_bug.cgi?id=323230 – user242293 Jan 31 '14 at 22:21
  • I moved the sidebar to the left of the screen (vertical), and the windows don't go under it anymore. – Mircea Oct 21 at 8:47
8

Unfortunately, it is a long known issue with X according to this page: http://forum.kde.org/viewtopic.php?f=66&t=102303

I was searching for a solution to similar problem when I came across this page.

2

I'm running plasma 5.6.5 with 3 screens attached. Everything is fine as long as the panel is horizontal - once I move this panel to the side, it stops reserving space for itself and allow windows to go under. I attached my display configuration - everything seems to be aligned there...

my display configuration

  • Thank you! Aligning the taskbars fixed this for me as well :] – masterwok Oct 31 '18 at 13:44
1

Possible workaround: align the tops of your two monitors in the KDE Display Configuration.

I have taskbars at the top and bottom of my primary monitor, and a secondary monitor with a higher vertical resolution than the primary. If the tops of my two monitors are aligned, then windows maximize properly. Otherwise, they maximize to the top of the screen, rather than the bottom of the top taskbar.

1

I had this issue and solved by going to: System Settings > Display and Monitor > Display Configuration

"Primary display" was set to "No Primary Output".

I set it to my left screen where I have the panel bar, it fixed it, maximized windows don't go below anymore.

I understand this might not be the primary issue but it should fix it for some of us.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.