I am running Ubuntu 10.10 amd64 in a Virtualbox on windows host. whenever i try to take a screenshot by pressing the print screen or by launching the gnome-screenshot option the screenshot appears completely black. any idea how to get a screenshot inside the Virtualbox?

up vote 11 down vote accepted

Ok guys! I have found out the problem and the solution. :P

The problem is Compiz and the solution is to disable it using the command:

metacity --replace &

Now, I can take screenshot of any window inside the VirtualBox.

  • Well... this kills all my icons and everything... so partial credit... – Philip Adler Dec 17 '15 at 15:47
  • This does not work for me on Mint 17.1 inside Win 8.1. If I use this to try to take a screenshot, I just get a screenshot of my background. It does not matter which application I try to take a picture of (Terminal, Firefox, folder explorer, ...). – Deleet Sep 21 '16 at 18:09

In Ubuntu guest go to System -> Preferences -> Keyboard Shortcuts. On the following window define a new shortcut to take a screenshot (e.g. in this example ShiftAltP):

enter image description here

Thenafter a screenshot will be taken whenever you press your keyboard shortcut. The default setting using Print is not available in the guest (host only).

Taking screenhots will not work with desktop effects activated, i.e. when Compiz is running (see here for reference).

  • Hi, Thanks for the idea, but even after this , i am unable to take a screenshot with any image. everything is dark in the screenshot. please see the attached screenshot image. i.imgur.com/RQkCP.png – Ubuntuser Feb 16 '11 at 18:38
  • o.k. my fault: I should have read your question better. Your shot is convincing ;). See Edit. – Takkat Feb 16 '11 at 19:28

A workaround would be to switch to windowed mode and take a screenshot of the VM window contents from the host OS.

  • thanks. yes thats a good idea. i discovered it 2 days back. +1 to u :) – Ubuntuser Apr 22 '11 at 20:59
  • I've been using this for a long time. It has some limitations. For instance, today I had to take a screenshot of a mouseover effect. Impossible with this method. – Deleet Sep 21 '16 at 18:04

I'm on windows 7 and you can use the snipping tool to take screenshots on ubuntu guest. I'm on a dual monitor setup though.

VirtualBox provides a menu option to take screenshots of the guest, View --> Take Screenshot (Host+E). Alternatively, just Host + E (that's usually Right Ctrl + E).

  • These screenshots from View_>Take Screenshot are currently blank(black empty pictures) for me, and doing a Print Screen not even toggled into the Host results in nothing in the copy paste buffer :( – Colin D Jul 31 at 19:26

I'm on Windows 7 running Ubuntu 11.10 on VirtualBox. Taking screenshots doesn't work for me either, but here's a workaround:

Press [Host Key] + Alt + Print Screen.

You can now access the screenshot from the host's (Windows) clipboard. The Host Key is by default Right Ctrl.

In VirtualBox 4.2.6 with Windows7-host and Ubuntu12.10-guest, I took correct screen shots before installing Guest Addition tools. After this, I get only black screens and desktop background image.

After disabling VirtualBox 3D acceleration in VM configuration, the problem seems to be gone.

Now I can use PrintScreen to take the full screen and Alt + PrintScreen to take a window screen shot through the gnome default capture utility.

  • Please detail precisely what you did and how you did it to solve the problem. – user98085 Feb 4 '13 at 22:15

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.