I can't install Ubuntu (12.10 and 12.04) (also tried Mint) on Z585 (Lenovo IdeaPad Z585 AMD A8-4500M 1.90GHz 8GB 1TB DVDRW DL FreeDOS 15.6" HD AMD Radeon HD7670 2GB).

I tested all possible options and still no luck so this is my call for the help.. Hope that someone knows something that is not yet listed:)

EDIT the steps I made:

  1. disable UEFI (also tried with enabled)
  2. Attempt to install Ubuntu from DVD
  3. Select "Install Ubuntu"
  4. Change options: acpi=off; nomodeset (tried all combinations)
  5. Press enter.

Result: Shown a black screen with blinking cursor- no errors no nothing, I can't enter anything and I can only turn off the laptop via shut button (by holding it) so I never got trough installation (Same thing I get if I do "Try" instead of "install").

Note that I had no trouble installing Windows 7.

p.s. I also tried the following:

My computer boots to a black screen, what options do I have to fix it?

Booting Ubuntu with "acpi=off" grub parameter


How do I set 'nomodeset' after I've already installed Ubuntu?

BTW I get stuck every time on black screen with blinking cursor only.


  • What happens when you try to install? How far do you get? Do you get any error messages? You should edit your question to include these, so that we can better help you. – Shauna Mar 11 '13 at 17:43
  • No, it has FreeDOS preinstalled. – sinek Mar 11 '13 at 19:49
  • @Shauna Sorry, what info? I've followed installation steps to install from cd (askubuntu.com/questions/162075/…) – sinek Mar 12 '13 at 13:11
  • Read my first comment. Those are questions you should provide answers to. Also, are you able to go through the installation, and first boot doesn't work, or do you not even get that far? Can you boot to the live CD? If you tap an arrow key on the blinking cursor screen, do you get any messages? – Shauna Mar 12 '13 at 14:03
  • 1
    @krisnik - please look at this part of that thread and try the ideas - please update your question with the results. Thanks. ubuntuforums.org/… – fossfreedom Mar 15 '13 at 11:35

I would give a try booting from USB, the advantage is that you can check the iso-image afterwards with md5sum. Sometimes simple read/write errors can cause unusual beheaviour of a self-burned image-cd.

  • I tried it (followed these steps) but no luck. I get the same results. – sinek Mar 21 '13 at 8:49
  • Did you check the DVD for errors ?
  • Did you try with a CD, a DVD and a USB flash drive ?
  • Did you try updating your BIOS to the latest version ?
  • Did you try removing every unnecessary device like external mouse, external keyboard, webcams or even disabling your USB ports and network cards in the BIOS ? (I can do this on my ThinkPad, I don't know if this is available on an IdeaPad)
  • Did you try using an older version and upgrading ?
  • Did you try with 32 and 64 bits versions ?

Good luck!

  • The only thing I didn't tried is 32 bits version. Everything else yields the same results. I think I'll just give up and go with windows. – sinek Mar 21 '13 at 8:50
  • Don't surrender yet. You can try deactivating Intel Smart Response Technology. Read more at : help.ubuntu.com/community/UEFI – phil Mar 21 '13 at 13:50
  • See my question. I already tried that. Note that in that case I end up with a blinking cursor instead of a black screen:) – sinek Mar 21 '13 at 13:55
  • It seems everyone with an AMD APU have a similar problem, try ubuntuforums.org/… again (I know you've already tried nomodeset) – phil Mar 21 '13 at 16:21

Try this:

  1. Quick possible solution: What you describe looks like a Graphic card problem. Try to disable the card by running notebook with powersave option, not the performance option. Performace forces 3D card running all the time and can cause a problem.
  2. If this does not help, download fresh ISO, get PendriveLinux http://www.pendrivelinux.com/yumi-multiboot-usb-creator/ and try Live without install, to confirm that it is working in general and it is not caused by installation process.

I have xubuntu on Z560/Nvidia with almost no problem, but the support of the G. card can sometimes fail on specific kernel-driver configurations.


I managed to install 12.10 on a Z585.

In the preinstalled Windows 8, hold Shift when clicking on "Shutdown", then click yourself through the menu to make it boot into the UEFI options (you have managed that already so just do it again).

There, disable all options regarind Windows, e.g.:

Optimized for [Other OS]

etc., until it says:

Secure Boot [Off]

After that, I was able to install Ubuntu without problems.

Sorry for the vague description, I don't recall the individual steps any longer and can not find the website I used for instructions.


I successfully installed openSUSE in UEFI mode on my IdeadPad Z585, in dual boot with Windows 10. I know it's possible now to do the same with Debian and Ubuntu.The only way I managed to make it work in legacy mode in the past was by using a 32-bit version, which wasn't ideal. Here's a good video that explains how to do it step by step. I hope it helps. https://www.youtube.com/watch?v=WulgG1GeJ4U It shows how to do it on Elementary OS, but since it's based on Ubuntu, it should work. Have fun!

  • Welcome to Ask Ubuntu. ;-) As videos do not contain any text that is searchable, pure video answers are not allowed here... Therefore, please edit your answer, and copy the relevant steps from the video into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link to the video at the bottom of your answer as a source for your material... – Fabby Aug 25 '15 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.