0

I am installing LocalWiki on a Virtual Machine hosted by 1&1.com It is Ubuntu 12.04.

When I run sudo apt-get install localwiki as instructed by http://localwiki.org/install/,

I get the following error

The following packages have unmet dependencies:
localwiki : Depends: postgresql-9.1-postgis but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried on my own to install postgresql but I ended up making things worse. I just did a clean install on 12.04 and I was wondering if someone here could assist me further.

Thanks.

edit: I even ran sudo apt-get install postgresql successfully and I still get the same error.
edit: I also want to point out that I think it may be something with my server. It says that 1&1 installs the OS with minimal OS. When I tried the instructions of localwiki on a VM on my local machine with 12.04, they worked perfectly. So I probably need to update something on my VM I am renting from 1and1?
edit: I downgraded to 9.1.5, since in another questions on here that seemed to work. It didn't work for me :(

1
  • 1
    Please try to incorporate edits properly into the body of your question by rewriting the relevant part of the question as opposed to adding them at the end of the question.
    – user25656
    Mar 11, 2013 at 3:48

1 Answer 1

1

Install the missing package. It will pull in postgres-9.1 (not the other way around):

sudo apt-get install postgresql-9.1-postgis localwiki
2
  • That still did not work. I get the same error Mar 11, 2013 at 23:33
  • @PolarisUser Please include in your question the full output of apt-get update; apt-get install postgres-9.1-postgis
    – zwets
    Mar 12, 2013 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.