16

I can't switch workspaces using the panel or the shortcut[Ctrl+alt+left/right>]. When I click on the workspace panel, there is no response. How do i fix this problem?

25

If you are using compiz, go to System/Preferences/Compizconfig Settings Manager" and lead to the "Desktop Wall" options.

Make sure you are using Desktop Wall, otherwise you may be using "Desktop Cube" in which case you should open "Rotate Cube".

In both cases, first make sure that the check box that enables the feature is activated, then properly configure your key bindings.

If they are already set and your keyboard don't activates the function, try with a different combination. Please inform if this didn't help in order to look for a different solution.

BTW: If you change key bindings and can't return to your initial screen, where "CompizConfig Settings Manager" is, try using the Super + E in order to activate "Expo", when open you can choose the desktop where you wish to go with the mouse or moving your selection with the arrow keys.

Good Luck!

A screenshot is placed here for you to see the Desktop Wall key binding config section. enter image description here

  • 1
    I have the same problem, but your solution did not work for me :(. Even after making sure Desktop Wall is activated, and checked my binding config, it still doesn't work. EDIT: Desktop size was configured to be 1x1 instead of 2x2, works fine now :D. Consider adding that to your answer :) Good day. – Madara Uchiha May 14 '13 at 11:40
7

Check if your Desktop Size ain't set to 1x1.

Compiz > General > "General settings" > Desktop size

Credits: Madara Uchiha's comment above, which led me to remembering this also can be an issue.

I'm posting that as an answer, because I've stumbled on it three times so far, while I've never yet had the problem with cube turned on or bindings lost.

EDIT: added an image since I have localized Ubuntu, so may be off with translations, so I'm highlighting which icons to follow. This is for Ubuntu 14.04. Compiz screenshot how to get to "General settings"

  • 1
    This should be checked before trying anything, I spent 4 hours before coming to this answer. – Kishor Pawar Mar 21 '16 at 13:55
  • 1
    I now have 25 workspaces! :D – thymaro Aug 10 '18 at 6:01
  • @thymaro and what do you do with them? :D – LAFK says Reinstate Monica Aug 11 '18 at 19:18
  • 1
    @LIttleAncientForestKami boot, switch between workspaces for a while, shutdown, lean back while breathing out a lengthy, blissful "aaaah". Also smile some. – thymaro Aug 11 '18 at 23:26
1

I just found another workaround. I reduced the number of workspaces to one in the preferences of the workplace-switcher applet I normally use. I have the desktop cube, expo, and several other compiz effects disabled, so they already weren't working. This only happens for me with Virtualbox running, and I get a virtual machine moved to a workspace that I can't get to. Crazy. Once I'm at only one workspace, all open windows are accessible

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.