I'm not sure which update did it - but at some point recently something broke my Desktop. I now have a grey background (instead of the gradient colour I had before) and no Desktop icons. Right clicking on the Desktop doesn't produce a menu any more, either.

My theme, sounds etc all seem to have been forcibly changed as well.

Also, when I attempt to start Phpstorm, it hangs on the splashscreen, and console shows:

Error parsing gtk-icon-sizes string: ''

Anyone have a suggestion how I fix it, or even diagnose what the problem is?

  • Log out of any graphical sessions, go to a text terminal (alt-ctrl-F1) then switch display managers with the following commands: sudo stop gdm then sudo start lightdm. – horIzoN Mar 10 '13 at 17:23
  • Thanks nerof61 - unfortunately it made no difference. gdm wasn't running, and restarting lightdm had no effect. Any other ideas? – hippyjim Mar 10 '13 at 18:08
  • You could try xfwm4 --replace and/or xfdesktop --reload and see if that helps, but your problem may need more than that to solve it. That error message usually appears if you have a broken theme installed, so there might be some errors in your gtk rc files if you are using custom themes or settings. Are there any clues in your .xsession-errors or .xsession-errors.old? – user76204 Mar 10 '13 at 19:33
  • Are you running Xfce 4.8 (stock version with Precise)? or a later version?, as there was a recent problem with xfdesktop in Xfce 4.10, for which a fix should be available very soon. – user76204 Mar 10 '13 at 23:37

I had similar problem with my Xfce. I restarted window manager by typing: xfwm4 --replace but it did not resolved the problem. I checked the xfce troubleshooting section in here: https://wiki.archlinux.org/index.php/Xfce#Troubleshooting and they are also suggest to delete the session folder by typing: rm -r ~/.cache/sessions/ and after that system has to be rebooted, and I have got my desktop back after reboot.

  • yeah, I did similar. Forgot I'd asked this question! Thanks. – hippyjim Aug 31 '13 at 7:58

If you had a power failure or some other type of system crash, first try this

xfdesktop &

And other obvious fixes such as clearing your session cache...But if you are still unable to get your icons back, then you might try upgrading to the latest xfce version.

I ran into a very similar problem with xubuntu 13.04 this morning. It occurred immediately after an dist-upgrade and subsequent reboot, thought I'm not sure if this caused the problem. I tried all of the suggestions here and in other threads to no avail - with the exception of the last post.

Finally I decided to give upgrading my xfce version a try:

sudo apt-add-repository ppa:xubuntu-dev/xfce-4.12

and because it was required per the developers:

sudo apt-add-repository ppa:xubuntu-dev/xfce-4.10


sudo apt-get update && sudo apt-get upgrade

Upon reboot everything was back to normal. I did not have to reinstall any packages, as was the case for others, to get my beloved desktop setting back. This took up most of my day, so I hope this helps someone avoid this particular trouble spot.

  • In my case, I had a number of issues possibly related to bugs fixed in xfce4.12. – user189860 Sep 5 '13 at 14:16

I had the same error. I tried to update xfce via ppa:xubuntu-dev/xfce-4.12. But it has only installed some parts. Afterwards xfdesktop was missing.

In my case it just helped to reinstall xfdesktop:

sudo apt-get install xfdesktop4

I removed .config/xfce4/ completely After login the default xfce4 dir is created with the correct contents and it is working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.