I've just installed my first linux installation on a donated computer that I plan to network and use it as a shared storage drive for all of our pictures and videos.

We have a DSL modem with both wired and wireless being available to this computer. At this point, wireless is not an option for us to use (no antenna on the wifi card and we're not going to put money into this machine) but it was working out of the box when brought into really close range to the router.

We have ran an ethernet cable from the router to the machine. Unity informs us that the wired connection is disconnected.. it's not!

After probing around on the internet I tried the following

cat /etc/network/interfaces

The following was returned (from memory):

auth lo
iface lo inet loopback

So, I added an eth0 portion to that file and saved it using pico. It then looked like:

auth lo
iface lo inet loopback
auth eth0
iface eth0 inet dhcp

And ran the following commands:

sudo ifdown eth0

Which just returned the command prompt, and then:

sudo ifup eth0

Which just hangs. Then after rebooting it boots with network configuration disabled and I changed the /etc/network/interfaces file back to what it was.

Can someone help me get my wired connection working, or help me help you guys by providing you with more relevant information?



  • After doing the commands that make it right, do sudo update-grub. You may need to do this. – horIzoN Mar 10 '13 at 9:47
  • After adding the lines back into /etc/network/interfaces I performed sudo udpate-grub as you said. It completed. I then tried the ifdown command which reports eth0 is not configured. ifup still hangs. – Scott Mar 10 '13 at 10:02
  • After performing sudo update-grub, reboot. – horIzoN Mar 10 '13 at 10:13
  • I just re-did it again, this time letting sudo ifup eth0 complete and it did, returning me to the command prompt. I then did sudo update-grub and it completed. I then rebooted, and was informed that ubuntu was starting without full networking. There is now no network icon in unity. I performed sudo ifup eth0 and response was ifup: eth0 already configured. I checked the internet connection by browsing to a web page in firefox and it is not connected. – Scott Mar 10 '13 at 10:19
  • If Unity has gone, try unity --reset. – horIzoN Mar 10 '13 at 10:22

You should first check your DSL modem settings. According to the model, type: on your web browser and get in to the modem settings. You should disable MAc Filtering if it is enabled. You should enable LAN connection if it is disabled

Save the latest settings and restart DSL modem.

Finaly, press win button on the keyboad or open the dash with mouse and write "network" You will see a directory picture with a cable. Click and open it. You can see WIRED option there. Check. it must be "ON" and at the options side, choose Automatic DHCP.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.