This question already has an answer here:

I have an ASUS X55A-SPD0204O laptop. The rest of the FN+Fx (where x = number) like sound + - mute, screen turn off, wireless etc. work perfectly.

The problem is with the 2 brightness keys. They just won't work. Any suggestions?

marked as duplicate by terdon Oct 26 '16 at 16:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Can you please add the output of ls /sys/class/backlight and of cat /sys/class/backlight/*/brightness to the question. – mikewhatever Mar 20 '13 at 14:54
  • 3
    I'd also be interested in seeing the output of lspci | grep -i vga, as we might be dealing with hybrid graphics. – mikewhatever Mar 20 '13 at 15:03
  • 2
    Why is this question closed as "has been asked before" with a reference to a question asked after this one? Not to mention that the referenced question in turn actually references this question. – Andreas Jan 11 '17 at 9:02

Try adding acpi_backlight=vendor as a boot option. To do that, open a terminal window, and run

gksu gedit /etc/default/grub

Locate this line: GRUB_CMDLINE_LINUX="".

Edit it to look like this: GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Save the file, then, in a terminal, run sudo update-grub.

Reboot, and check if the brightness keys work.

  • 1
    Worked perfectly for my Asus UL50VT. Been trying to fix this problem for several years now. Thanks! – unknownone Mar 10 '13 at 5:05
  • 2
    @Dialogos, try acpi_osi=Linux or acpi_osi=linux acpi_backlight=vendor; I hope one of these will help. – AliNâ Mar 21 '13 at 0:30
  • 3
    Neither acpi_backlight=vendor nor acpi_osi=linux acpi_backlight=vendor worked for me. The working one for me was acpi_osi=Linux as @AliNa commented. Debian Wheezy on Asus UX50V Laptop – Stichoza Jan 31 '14 at 16:21
  • 1
    acpi_osi_Linux did it for me, too, thanks @Stichoza – avalancha Apr 10 '14 at 21:11
  • 1
    First suggestion solved it for me on Ubuntu 14.04 running on a Lenovo ThinkPad – Florian Loch Jun 20 '14 at 12:16

You can try to control it from command line and give mesage back if this works in general:

You will need xrandr

xrandr --current --verbose - this will display your current display mode / modes

important is name of your output (clould be LVDS1 or LVDS-0)

xrandr --output <outputname> --brightness 0.5 - this should control your brightnes, you can try different values. Do not use zero (0) what means lamp is switched off and you will see Big nothing. be careful, some types of devices have completely different set of values (as 0-255, etc. Unfortunatelly I do not have your ASUS to test it)

This will work probably independently of the brightness settings reachable normally via keys. If this works, I recommend to watch for key bindings. Advantage is, you can control brightness of external VGA output as well.

Upgrade the grub and try you may be able to get the brightness working properly. You may follow this link and to upgrade and fix the brightness problem for your PC.

Are you able to change the brightness in system settings (Power manager)? If yes, then maybe just keys are not binded.

You could install xbacklight and bind your special keys to appropriate commands.

  • yes i can change it manually. – Dialogos Mar 22 '13 at 23:03

try that .. i had your same problem and it work with me

Open a terminal window and type the following:

sudo nano /etc/X11/xorg.conf

This will open your X server configuration (after prompting for your password). You should see a section titled "Device" that looks as follows:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
EndSection

Append a line so it appears like this:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

You will need to restart your graphical server (or reboot) for this change to take effect.

PS: I tried all suggested solutions here and nothing worked with me!

it seems like there are 2 solutions for this problem, but sometimes none of these work. I tried changing the boot options (editing-updating grub and stuff) and that didn't work. As I have seen in many forums (and in my case too), the change in the xorg.conf file won't work because there is no such file... so?

After searching a couple hours, I found something interesting:

sudo nvidia-xconfig
sudo reboot

those lines supposedly get the driver working as it should, but the original problem remains. The important thing is that those lines CREATE the xorg.conf file, so now it is possible to apply the second solution (adding the Option "RegistryDwords" "EnableBrightnessControl=1" line to the file).

Hope this helps someone, I used this on a Samsung R580, with a Nvidia GeForce310m and worked just fine.

By the way, I used sudo gedit /etc/X11/xorg.conf instead of the nano command, it's just a matter of tastes I guess...

Try this app .. for problem in brightness controlling. Use the following commands

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt-get update
sudo apt-get install brightness-controller

I was also searching stuff related to driver , but at last I found this app . I am having ubuntu - 12.04 on Sony - vaio, working fine for me.

just install power-manager relative to your xwindow system (eg. I use xfce4-power-manager). That solves the screen brightness adjusting from fn keys without messing around with grub.

Not the answer you're looking for? Browse other questions tagged or ask your own question.