I have the following setup:

  • Samsung 840 Series SSD drive with three partitions:

    1. EFI Boot Partition (200 MB)
    2. Linux Swap Space (2 GB)
    3. Primary Ubuntu Drive (490 GB)
  • Crucial M4 SSD with one partition:

    1. Windows 8 Pro Drive (250GB)

The SSD drives are new, and the Windows 8 was installed before Ubuntu.

I set the boot on my BIOS (AsRock Extreme4) to go to the Ubuntu GRUB loader, which lists a couple options for booting ubuntu as well as an option for booting Windows 8. Ubuntu loads without any problem.

Whenever I try to load the Windows 8 OS, I get the following error:

Grub Can't find command 'Drive Map'

I have tried accessing the M4 drive from Ubuntu to see if I can find the boot location on the NTFS windows drive, but I can't mount the Windows drive to Ubuntu, because it gives this error:

Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is hibernated.

Is there an easier way to fix the grub boot commands that involves not mounting the Windows 8 drive to Ubuntu?

EDIT: I tried using the Ubuntu Boot Repiar tool from a LinuxLive USB loader. The "Recommended" fix didn't fix anything, but it gave me this paste file, detailing my boot setup, if it helps: http://paste.ubuntu.com/5600941/

I think the major problem lay in that the Windows partition is on another disk, which can't be mounted in Ubuntu, hence I can't use grub probe without getting errors.

EDIT 2: [SOLUTION] I ended up just reformatting the Ubuntu drive again, and installing Ubuntu via LiveUSB with the LinuxSecureRemix Ubuntu ISO found here. This was installed across two partitions on the drive - one for Swap and one for Ubuntu.

Then I loaded Ubuntu on the new partition, and used GParted to create an EFI partition alongside the Ubuntu and Swap partitions, making sure the EFI partition was created first and then flagged boot_EFI second. Then I ran Boot-Repair, and used recommended settings.

Boot-Repair was finally able to detect the now-blank boot_EFI partition, and install Grub. For whatever reason before, it was not able to use EFI partition created with the Ubuntu install.

Now Ubuntu Grub works with windows 8.

IF you are having trouble with Windows 8 and Ubuntu grub, boot-repair, or burg I would recommend reading here first before you try the reformat that I did.

  • Welcome to Ask Ubuntu! This question will probably be closed as a duplicate soon. If those answers don't fully address your question please edit it to include why and flag this for re-opening. Thanks! – Seth Mar 10 '13 at 0:43
  • I ran the Ubuntu Bootloader fix tool from a liveUSB mount, and did the "recommended" fix. No dice - grub still gives the same error message. – Jabberwockey Mar 10 '13 at 4:30
  • I also tried to do the custom menuentry for grub using the fix mentioned in the other ask Ubuntu questions. Even experimenting with the different drives/partitions it still doesn't work. It's been a lot of rebooting. :( – Jabberwockey Mar 10 '13 at 4:32
  • Have you seen this: askubuntu.com/q/221835/44179 ? – Seth Mar 10 '13 at 13:31

You could try installing rEFInd, which is an alternative to GRUB that usually handles Windows more reliably. If you're using Ubuntu 12.10 with its default installation settings, you should be able to install the rEFInd Debian package and everything will work correctly, although there may be duplicate menu entries. You can remove these by editing the /boot/efi/EFI/refind/refind.conf file and adjusting the dont_scan_dirs or dont_scan_files options.

| improve this answer | |
  • I got some strange results. The rEFInd installed, then loaded properly on the boot. I saw my two partitions plus a couple backup load options. The strange thing is that when I loaded the Windows boot option, it went then went to Grub - where I saw the Ubuntu and Windows options again (in grub). Selecting windows this time gives the same error. – Jabberwockey Mar 10 '13 at 5:01
  • Is there any way to check if grub is install in the boot on the windows drive? I can get windows to load when I set my Bios to boo t the windows drive, so I don't think that would be the case. – Jabberwockey Mar 10 '13 at 5:01
  • Do this in Linux: sudo cp /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi.grb /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi. It should then be possible to boot Windows. – Rod Smith Mar 10 '13 at 17:49
  • Thanks, but my windows 8 boot is on an entirely different drive than Ubuntu, and I couldn't access the drive (or boot folder) in Ubuntu. – Jabberwockey Mar 13 '13 at 5:48
  • Upon reviewing your Boot Repair output again, it seems your system has been configured to hide your ESP by changing /etc/fstab to comment out the entry that mounts /dev/sda1 to /boot/efi. Try either uncommenting that line (which begins with #UUID=6FF4-3137 /boot/efi) and typing sudo mount -a or type sudo mount /dev/sda1 /boot/efi before copying the bootmgfw.efi.grb file to bootmgfw.efi. – Rod Smith Mar 13 '13 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.