52

I have installed Ubuntu 13.04 and set my local time/date and its working, the only thing thats bugging me is that I cannot change it to English. I would like to do this because its hard to read and its not showing in proper format in Terminal, please view the screenshot below.

enter image description here

Show in proper formate

enter image description here

Not showing in proper format in terminal

How can I change my date/time to English format and keep the local time?

65

click on system settings.

System Settings icon in launcher

Click on Language Support.

Language Support icon in System Settings

Click on the Regional Formats Tab, and change language to English, and apply system- wide. and that will do it.

Note: You may have to relogin, so changes can take effect

Regional Formats settings

  • 6
    Thanks for your answer, @Mitch. I used it, it works but just as a tip I am writing. We don't need to reboot, we just need to re-login. Just log out and then login again. So, that will make your answer even more efficient and accurate. ;-) – Afzaal Ahmad Zeeshan Aug 31 '15 at 18:40
  • @AfzaalAhmadZeeshan that makes more sense. +1 for the keynote! – Kulasangar Sep 27 '17 at 20:43
5

Choose the New York time when installing Ubuntu 13.04, And do the following steps for you local time.

1.Click on settings > Click on Time & Date

enter image description here

It need to me check, By default it will be, if not check it

2.Click on Clock and check Time in auto-detection location

enter image description here

3.Wait few minutes and you will see you local time just above shutdown button

enter image description here

OR

enter image description here

Click on it

Done


enter image description here

  • This changes the time and date not the time and date format. -1 – David Foerster Jan 30 '17 at 2:52
3

The problem with the answer mitch gave is that after changing regional settings, the alt-shift keyboard language toggle get screwed up.

So you can either fix it with:

setxkbmap -option grp:alt_shift_toggle us,?? (where ?? is your other language)

Or, you can go for another solution. Instead of doing what mitch suggested, you can change specifically what you want to change.

From the terminal enter locale to see a list of the different language variables in your system, and then you can just change them, all, or specific. For example, entering:

LC_TIME=en_US.UTF-8

will change the date and time back to US-English.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.