How could I setup a dual boot for Ubuntu and Windows 8 on my Microsoft Surface Pro with 128 GB.

Note: My dual boot solution is below.


1 Answer 1


Video Demo

EDIT: July 11, 2014 @ 6:00PM PST

This has been updated to reflect changes in 14.10 AMD64. (14.04 LTS works fine but 14.10 works awesome out of the box.)

  • Removed boot repair process. ( This seems to be fine in this release. If you have issues you may want to make sure Grub2 is installed and to run the boot-repair process.)

  • Added bootloader section, again. (Note: Someone fixed the bootloader issue that was causing customized loaders not to work for GRUB2.)


Create a partitioned drive.

  • Press search button on your keyboard type 'boot'.
  • Select 'settings >> Create and format disk partitions'

enter image description here

  • Select C drive, right click and select 'shrink volume'.
  • This is your choice but I use appox. 29.3 Gigs(30,000 MB): Shrink respectively.

enter image description here


Follow the instructions on Geek.com.

  • Stop at prompt to delete disk or partition.
  • Return and follow instructions.

    note: I suggest using your SD drive as there seems to be USB compatibility issues in some cases. Also you can simply mount the ISO in Windows and copy the contents to the storage drive, SD or flash.


Prepare partitioned space for install.

  • Change the selection from 'Delete and Install' to 'Something Else' at the bottom.

enter image description here

  • It will ask if you want to unmount your installation device. Select 'No'.
  • Now select the free space and press the '+' button under the partitions.
  • Select from the drop list 'swap' and select the 'logical' radio button and 'insert at beginning' and finish. Select anywhere from 400 to 600 MB to be safe at least.

enter image description here

  • Now select the free space and press the 'change' button - again.
  • Select from the drop list 'Ext4' and select the 'primary' radio button, 'insert at beginning', 'format' button checked and '/' as root and finish. Use the remaining space you have reserved.

enter image description here

  • Finish install process on the Ext4 partition you created.

Now you can restart.


The Intel cpu needs a fan sensor update. I suggest doing this with lm-sensors.

sudo apt-get install lm-sensors
sudo sensors-detect
  • Select 'YES' to everything and follow the end instruct
  • It will ask you to run some sudo commands after it is done.


Not required but if you have made it this far you want a awesome beautiful device. That ugly boot loader didn't do it for me so I created a boot loader just for the surface.

  • Go Download from my github.
  • Follow README instructions to setup.

enter image description here

  • 2
    Why are we formatting the partition as FAT32 only to format it as EXT4 later? Isn't that pointless? Mar 9, 2013 at 2:19
  • 1
    Alright - I've got the Wi-Fi going. The embarrassing truth: I had connected successfully already but did not know it. I thought the Network Connections Panel and Wireless Icon in the top bar would reflect any changes. No. I simply had to open my browser and give it a go. Now that the extent of my ineptitude is made clear (haha), I admit I cannot understand how to install the boot menu. When I run the second line of code, I get the feedback cp: cannot stat ./surface': No such file or directory ` I've never used GitHub - am I missing an obvious step? I'm guessing I am. :)
    – TX-NY-CA
    Jun 30, 2013 at 1:48
  • 1
    @Mittenchops There is a bug currently that makes my system have the same issues but only from time to time. You may want to try and reboot a couple times or you may have had something go wrong in the installation process and may need to delete what you have done and try again. I will suggest downloading the daily image for 14.04 though as I seem to be having less bug issues. I will be adding an update soon to reflectt installation of 1.04 only. Mar 17, 2014 at 20:53
  • 1
    Here's a thing I've been struggling with (and solved it), so I'll add it for the few who are confused about this as well. If you happen to download the i386 version of Ubuntu (not the AMD64), then chances are it might not boot and you'll spend hours trying it to boot. I read over that part which was a costly mistake :) Oct 13, 2014 at 8:48
  • 1
    I also couldn't find 25_custom, so I added the question. Two hours after this comment I answered it as well. The answer should be reflected in this tutorial for 14.10, because it's confusing the way it is now! askubuntu.com/questions/536470/… Oct 13, 2014 at 10:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .