I'm trying to get multi-touch gestures working on my Dell XPS 15. Two finger scrolling works but three or four finger gestures do not. I know that the touchpad is capable of multi-touch gestures because it works fine in Windows. I've tried several things already:

  • Installing touchegg from the repository
  • Installing touchegg from source
  • Installing Sputnik kernel and policykit updates from Sputnik PPAs

The first fails with a segmentation fault when run, the second gives errors during compile about missing files, and the third installed fine but nothing changed. Compilation errors can be seen here.

  • 2
    ubuntuforums.org/showthread.php?t=2051324 That's pretty much the closest you can get to a "god" experience with the XPS L521X's touchpad!!! – user262684 Mar 27 '14 at 18:31
  • Of course Windows can't either. The driver that comes with your laptop can do that. Try using Windows without the driver. And since linux is sometimes out of luck in case of drivers, specially for touchpad, I'd say don't put much hope in it. Just my opinion. – Soroosh129 May 1 '14 at 22:31
  • 1
    Have you tried Ubuntu 14.04? – HarlemSquirrel May 7 '14 at 16:56
  • 1
    @HarlemSquirrel: I'm using it now and it hasn't solved the problem. – Nimble May 8 '14 at 2:28
  • Nimble, have you looked at this wiki page? wiki.ubuntu.com/Multitouch – HarlemSquirrel May 9 '14 at 12:47

Try this solution.

Install xserver-xorg-input-multitouch and xserver-xorg-input-synaptics

sudo apt-get update
sudo apt-get install xserver-xorg-input-multitouch
sudo apt-get install xserver-xorg-input-synpatics

It has solved touchpad issues on other brand name laptops, don't know about Dell.


In ubuntu 14.04 all working fine for me , i suggest you to upgrade to ubuntu 14.04 or try find out whats ubuntu 14.04 using that causing the difference . .


If you're using Ubuntu Unity, 3- and 4-touch gestures are reserved to the window manager (Unity), and the 3-finger window management gestures are disabled for touchpads. I'm no longer clear on the rationale behind disabling them for touchpads, it was done in early in 2013.

Not the answer you're looking for? Browse other questions tagged or ask your own question.