I have an Ubuntu Quantal MAAS server and some computing nodes. I'm trying to set up an OpenStack cloud by following the Ubuntu Cloud Infrastructure walkthrough. Everything looks okay...I can bootstrap juju, deploy the charms (maas nodes are booting precise), log into the dashboard, register images, and even boot vms, BUT networking is not working at all. I'm trying to use the FlatDHCPManager on nodes with two ethernet interfaces. I've verified separately that connectivity is not an issue (e.g., all the eth0s are on the same switch, all the eth1s are on a different switch, and if I just statically assign IP addresses on either network the nodes can communicate with each other). When I ssh into the nova-cloud-controller or nova-compute machine I can see that the bridge is never created and eth1 is not active. Also, nova-network is never installed on any machine.

I've successfully gotten openstack up and running using devstack, so I know it will all run on my system, but I'd really like to get things working with juju.


  1. should nova network be installed?
  2. if openstack is installed correctly should I be able to connect to nova-cloud-controller and nova-compute and see the bridge set up? (and if so, does this happen before or after setting up relations)
  3. and does anyone have any ideas on what I could try to fix the problem?
  • Have you found your way around it? – dhojgaard Mar 15 '13 at 15:33

I've had the same problem. Also the vnc packages is also never installed. It seems to me that the charms is not fully functioning, or i may be missing something...

However i made it work by setting up the networking my self.

Created a bridge 'br100' and made sure the interface linked to the bridge was set for promiscuous mode. This has to be done on controller and all compute nodes. Then of course you have to update nova.conf with the right information and use the command nova-manage to create the networks.

This blog post was crucial for me: http://www.mirantis.com/blog/openstack-networking-single-host-flatdhcpmanager/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.