6

I've tried to set up a trivial repository with binary .debs for internal use, but apt-get doesn't see the packages. I've done the following:

On the web server:

  1. Created the binary debs with dpkg-buildpackage
  2. Put all of the binary debs in a web-accessible directory which corresponds to http://www.example.com/packages
  3. Generated a Packages.gz file in the same directory by doing:

    dpkg-scansources . /dev/null | gzip -9c > Packages.gz

On the client machine:

Added the following line to my /etc/apt/sources.list file:

deb http://www.example.com/packages /

Ran: sudo apt-get update

The output related to my trivial repository looked like this:

Ign http://www.example.com  Release.gpg
Ign http://www.example.com/packages/  Translation-en_US
Ign http://www.example.com  Release
Ign http://www.example.com  Packages
Ign http://www.example.com  Packages
Hit http://www.example.com  Packages

But I can't install the package by name. For example, there's a package called "python-nova" which corresponds to package python-nova_2011.3-custom~bzr680-0ubuntu1_all.deb

I've tried to do: apt-get install python-nova, but I get the following error:

$ sudo apt-get install python-nova
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package python-nova
4
  • Did you check the contents of Packages.gz on the server ? Does it contain the information for python-nova as expected ? Feb 15, 2011 at 22:09
  • 2
    can you try with dpkg-scanpackages instead of dpkg-scansources
    – jet
    Feb 15, 2011 at 22:52
  • Instead of doing things manually like that, use a tool for built for the task.
    – tshepang
    Feb 16, 2011 at 0:36
  • 1
    @jet That was it! I was using dpkg-scansources when I should have been using dpkg-scanpackages. If you add this as an answer, I'll accept it. Feb 16, 2011 at 1:53

1 Answer 1

3

can you try with dpkg-scanpackages instead of dpkg-scansources

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.