Sorry to ask this question which has been asked by dozens of other people, but it seems that though the symptoms may be the same, most people have different issues. I installed Ubuntu 12.10 on my Acer Aspire5100-5023 computer which has its own issues (particularly that there isn't a compatible graphics driver for the onboard video and I'm using openGL, but that's a different story altogether).

The build in dvd-rw doesn't seem to be detected by ubuntu and an external dvd drive, an asus SDR-08B1-U slim dvd reader, doesn't seem to want to mount. It may be malfunctioning hardware, but it seems to unlikely that both should fail. Right now this question will focus on my external usb dvd reader, the asus SDR-08B1-U.

So the output of sudo lshw -C disk is

           description: SCSI Disk
           product: 10EACS External
           vendor: WD
           physical id: 0.0.0
           bus info: scsi@2:0.0.0
           logical name: /dev/sda
           version: 1.65
           serial: WD-WCAU40146829
           size: 931GiB (1TB)
           capabilities: partitioned partitioned:dos
           configuration: ansiversion=4 sectorsize=512 signature=44fdfe06
           description: SCSI Disk
           physical id: 0.0.0
           bus info: scsi@5:0.0.0
           logical name: /dev/sdb
           size: 14GiB (15GB)
           capabilities: partitioned partitioned:dos
           configuration: sectorsize=512 signature=c3072e18
           description: SCSI Disk
           physical id: 0.0.0
           bus info: scsi@6:0.0.0
           logical name: /dev/sdc
           size: 7441MiB (7803MB)
           capabilities: partitioned partitioned:dos
           configuration: sectorsize=512 signature=c3072e18
           description: DVD reader
           product: SDR-08B1-U
           vendor: ASUS
           physical id: 0.0.0
           bus info: scsi@7:0.0.0
           logical name: /dev/cdrom
           logical name: /dev/dvd
           logical name: /dev/sr0
           version: 1.00
           capabilities: removable audio dvd
           configuration: status=busy

I tried to mount the drive manually by creating a directory /media/myusername/cdrom0 and typing in

sudo mount /dev/sr0 /media/myusername/cdrom0

but that results in

mount: /dev/sr0 already mounted or /media/myusername/cdrom0 busy

so then I tried

umount /dev/sr0

which returns

umount: /dev/sr0 is not mounted (according to mtab)

The drive is making sounds as if it is restarting itself constantly. The light indicating that it is operating is on. Now, previously when I used it with windows, it seemed to work, however, since then, on boot up, I get a fixed disk error with my harddrive and have been booting Ubuntu from and external usb harddrive since, which works remarkably well! But I can't verify that the drive is working 100%. However, rather than jump to the conclusion "it must be a hardware issue, gtfo" I would appreciate any possible suggestions to see it there is something else I can do. Alternatively, I'm opened to suggestions about my built in optical drive. It doesn't even show up when I use lshw but the drive does light up when I insert media.

So here's the output of dmesg | grep /dev/sr0

    [48868.707336] sr0: scsi3-mmc drive: 24x/24x cd/rw xa/form2 cdda pop-up
    [48868.707807] sr 5:0:0:0: Attached scsi CD-ROM sr0

Okay, so I looked around other questions and online forums for people with similar issues. Here's one command used to get information, though I'm not quite sure what the command actually does or what the information reflects. Sorry, I'm not an expert. Running wodim --prcap dev=/dev/sr0 returns

    wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
    Device type    : Removable CD-ROM
    Version        : 0
    Response Format: 2
    Capabilities   : 
    Vendor_info    : 'ASUS    '
    Identification : 'SDR-08B1-U      '
    Revision       : '1.00'
    Device seems to be: Generic mmc2 DVD-ROM.

    Drive capabilities, per MMC-3 page 2A:

      Does read CD-R media
      Does not write CD-R media
      Does read CD-RW media
      Does not write CD-RW media
      Does read DVD-ROM media
      Does read DVD-R media
      Does not write DVD-R media
      Does not read DVD-RAM media
      Does not write DVD-RAM media
      Does not support test writing

      Does read Mode 2 Form 1 blocks
      Does read Mode 2 Form 2 blocks
      Does read digital audio blocks
      Does restart non-streamed digital audio reads accurately
      Does not support Buffer-Underrun-Free recording
      Does read multi-session CDs
      Does read fixed-packet CD media using Method 2
      Does not read CD bar code
      Does read R-W subcode information
      Does not return R-W subcode de-interleaved and error-corrected
      Does read raw P-W subcode data from lead in
      Does return CD media catalog number
      Does return CD ISRC information
      Does support C2 error pointers
      Does not deliver composite A/V data

      Does play audio CDs
      Number of volume control levels: 256
      Does support individual volume control setting for each channel
      Does support independent mute setting for each channel
      Does not support digital output on port 1
      Does not support digital output on port 2

      Loading mechanism type: pop-up
      Does not support ejection of CD via START/STOP command
      Does not lock media on power up via prevent jumper
      Does not allow media to be locked in the drive via PREVENT/ALLOW command
      Is not currently in a media-locked state
      Does not support changing side of disk
      Does not have load-empty-slot-in-changer feature
      Does not support Individual Disk Present feature

      Maximum read  speed:  4233 kB/s (CD  24x, DVD  3x)
      Current read  speed:  4234 kB/s (CD  24x, DVD  3x)
      Maximum write speed:     0 kB/s (CD   0x, DVD  0x)
      Current write speed:     0 kB/s (CD   0x, DVD  0x)
      Rotational control selected: CLV/PCAV
      Buffer size in KB: 198
      Copy management revision supported: 1
      Number of supported write speeds: 0

CONFIRMED: A friend tested this drive on a netbook running windows 7 and it was able to run a dvd (starcraft 2 if anyone cares) without issues. Windows was able to access the drive without any drivers, just plug n play. So there is not an hardware issue/defect. Again, it sounds as though the drive restarts every few seconds when I plug it into Ubuntu 12.10. So the question is whether this is a bug or something else that can be fixed.

And here's the product spec page http://usa.asus.com/Optical_Storage/External_Slim_DVD_Drive/SDR08B1U/#specifications

  • well, it's been a while, there are some views but no comments no answers. I thought I should mention that the theory I'm going on for the malfunctioning internal optical drive is a defect in the manufacturing process. I've read that several people and Acer Aspire 5100 notebooks had opened up their laptops to discover that the cable from the dvd drive to the board has become dislodged. Also discovered that the fixed disk was common place and that the solution was to "push down on the plastic trim beneath the left windows key while booting." Explanation to this technique is that an ATI chip... – Nil Mar 8 '13 at 22:15
  • ... is loose. rok.my.sox from notebookreview.com solution was to place a small piece of rubber on top of the chip to hold it in place on the motherboard inside the laptop case. While I don't intend to bugger round inside my laptop now, I will eventually and report back whether those were hardware problems. The issue with the external drive, which is the primary topic of this page, still stands unsolved. – Nil Mar 8 '13 at 22:17
  • Well, no one has even commented. Can someone at least tell me where to find a log file to see if there are any errors? Also, does anyone have this kind of usb optical drive and do they have the same problem or is it unique to me? I.E. is it a bug or malfunctioning hardware? – Nil Mar 14 '13 at 17:26
  • Well, since I confirmed that it wasn't a hardware issue, I was thinking of filing a bug report. Problem is that ubuntu recommends I check to see if my bios is up to date before submitting one. Problem is I don't know how to update my bios from within ubuntu. I'm still unable to access my windows partition due to that bloody "fixed disk" error, which is most probably caused by a faulty chip on the laptop's motherboard. But seeing as how ubuntu can identify the dvd drive, I don't think updating bios will change anything. – Nil Mar 14 '13 at 19:27
  • 1
    That's o.k.- please put this as an answer in the box below, so we can see the problem has been solved. – user76204 Mar 14 '13 at 21:02

I found the problem and people are going to hate me for it. Two are connected to a single usb hub which uses a 2nd port for extra power. I had the dvd connected to the usb hub. I removed the hub and connected the dvd drive directly to the laptop and it worked. Apparently, despite using 2 usb ports, the hub wasn't able to provide enough power to the drive while allowing me to operate my mouse and keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.