I'm trying to install Ubuntu Server 12.04 from USB and I've been struggling with it for 3 days. I don't remember I had this hard time even when building my Hackintoshes.

So, now I'm at the point where I tried everything I found - Unetbootin, Startup disk creator, Live USB creator - nothing really works, as it doesn't detect the USB as a CD-ROM. I tried the switch cdrom-detect/try-usb=true to no avail. At least now I managed to get over this problem with the following method. I make the USB boot disk, I copy the *.iso to the USB too, I boot the installer and when I get the CD-ROM error, I ALT+F2 and do the following:

mkdir /usb
mount -t vfat /dev/sdb1 /usb
ls /usb (so I see the name of the ISO clearly)
mount -t iso9660 -o loop /usb/whatever-the-iso-is-called.iso /cdrom
ls /cdrom (so I see it has mounted the ISO right)

So mounting the ISO in a word. I select "Load configuration from CD-ROM" or something like that and I got rid of the CD-rom error. Everything's peachy until I get to the Configure APT screen, where it can't connect to the internet because I'm behind a firewall and it doesn't give me the choice to enter the proxy and it just quits to the installation choices screen. Now if I tell the installer to let me configure what software I want installed, it just tries to configure apt, it fails and it quits to the choices screen. Then I can continue the installation with install grub, it installs it and it works after restart.

BUT i have absolutely nothing installed, not even nano, my sources.list is empty with only the CD-ROM resources line. I don't know what to do... I need LAMP, SMB, SSL, CUPS installed - I don't want to do everything manually. Has anyone succeeded doing a start to finish installation using USB? If yes, how? BTW, everything works OK if you install from the CD (even if I plug the LAN cable out, it still configures apt and it still populates the sources.list). But I don't have a CD drive on the system I want to do the final install too and I don't want to buy any external CD drive just to get this done. All help welcome, I'm going crazy with this...

  • Not all computers can boot from USB, especially older ones. Maybe this is a dumb question but have you verified that your hardware is capable of booting from USB? Mar 7, 2013 at 19:25
  • It boots of course from usb, I installed many OS's from USB on this rig, including Mac OS X. But Ubuntu SERVER just doesn't want to play along...
    – gerdez
    Mar 8, 2013 at 7:07

2 Answers 2


So I managed to do it, I'll write it down, maybe others confronting this problem will make use of it.

When you get to the point where because of the enterprise firewall the installer can't configure APT, just select the next step - Install GRUB and finish installation. Now you can boot in a bare bone ubuntu server. Leave the USB connected, reboot and login to the new server. Mount the *.iso again as your sources.list will contain only the ubuntu server CDROM as repo. Now, when that's done:

sudo apt-get install nano tasksel
sudo tasksel --list-tasks
sudo tasksel install what-ever-you-want-from-list

Now on with configuring the proxy:

sudo nano /etc/environment

and configure proxy there:

ex. http_proxy="http://192.168.X.X:PORT/"

Then go to http://repogen.simplylinux.ch and generate your sources.list, paste it through SSH or somehow, then:

sudo apt-get update

You're done.

EDIT: btw, I tried the USB install from home, without proxy and my experience is that the installer still fails to configure APT and System Clock. So you have to do the after-boot CD mounting anyway if installing from USB. Interestingly, using a normal CD works fine.

  • +1 nice work. This must have been pretty frustrating to figure out! Mar 8, 2013 at 22:58

I have had similar problems with installs from USB devices and it not being able to mount the cd-rom (iso).

These two steps can quickly solve this issue:

  1. check your BIOS boot order settings and move your USB device to the top of the list.

  2. you may still get the same error message about being unable to mount the cd-rom, simply unplug the usb device and re-insert it then choose the option to retry detecting the cd-rom. 9 times out of ten it will now recognise the iso on the usb and begin the installation.

note if this does not work try restarting with the usb drive in a different usb slot and try them all one by one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.