I had managed to make bumblebee work yesterday and today i launch update manager and i see some new nvidia drivers. I dont know why but i installed them...

I shouldnt have done that lol

Now im back with this classic error

[   84.300183] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[   84.300310] [ERROR]Aborting because fallback start is disabled.

Of course I've googled it before, there are so many threads about this problem but I couldnt find a solution.

Ive blacklisted nouveau, i tried to blacklist nvidia

In the conf, driver=nvidia and kerneldrive=nvidia too

i dont know what to do anymore

i am thinking about removing linux and going back to 7, its so hard its so exhausting please help

  • Please search before posting a question,also the editor keeps giving suggestion. If you tried the answer & failed, mention that too. Here are few relevant questions - First try, sencond try & third try. Please remember, you modified /etc/bumblebee/bumblebee.conf. Please check the answer of 2nd link, I posted – Web-E Mar 7 '13 at 17:12
  • I already did all that and i wrote in my post that i had done it. Linux headers are not a problem. I think its relative to the new nvidia driver that I installed this morning and i suspect alot of people are gonna have the same problem than me... – Cotcot Mar 7 '13 at 17:21
  • maybe because of the primus update in bumblee 3.1? I will search a bit tommorow. i am not having any problem as of now. Please mention the graphics card model also,. By mentioning , I meant to say which answer you have tried already in my earlier comment.. btw Your first comment did came to my notification – Web-E Mar 7 '13 at 19:28
  • I have an Intel HD400 and geforce 650. – Cotcot Mar 8 '13 at 5:39
  • anyway i give up, my laptop is too much of a hassle to make it work with linux – Cotcot Mar 8 '13 at 7:24

I think that I was in this situation in the past and that this helped.

In the terminal type or copy paste:

sudo apt-get purge nvidia-current

Then to make the optimus card functional you can try to install bumblebee again here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.