Has anyone had problems with how Windows and Linux drivers configure the network card? I have a Realtek 8112L LAN Controller and am dual-booting Windows 7 and Ubuntu 10.10. After using network processes under both systems the network card stops working under either, forcing me to reset the CMOS.

Update The CMOS reset works but is not necessary for me. Shutting down and unplugging the power cord works as well.

I fear the only solution will be for someone to fix the driver, if anyone has another idea I would love to hear it.

  • Would you explain this futher, if this is still a problem? You say after using network processes.. Does that mean network card stops working in both windows and Ubuntu at times after working some time ? In that case it may be a hardware fault. – Jamess Mar 22 '11 at 6:30
  • @Jamess Yes, it's still a problem. It's not a hardware failure though otherwise there would be intermittent outages and I can reproduce the problem by running linux and then windows. I think hieukieng is right, linux loads a file to the network card that is incompatible with windows drivers. I would like to know if there are any fixes though. – Usagi Apr 7 '11 at 0:35

In my case, it works well on Ubuntu 10.10 but Win 7 cannot recognize the card. The solution is to cold reboot and wait for a few minutes then turn on and boot into Win 7 ( I googled somewhere but now I forgot). According to some explanation, Ubuntu loads some kind of firmware into the card that Win 7 cannot recognize. Anyway, it worked for me.

  • I'll give it a try, that would be easier than moving pins on the motherboard, I would still like a better fix. – Usagi Apr 7 '11 at 0:32
  • Cold reboot didn't work for me. – Usagi Apr 11 '11 at 23:32
  • Actually, if I shut down and unplug the power cord it does the trick, that's probably what you meant by cold reboot :) – Usagi May 2 '11 at 19:08

I was having the same problem. Windows 7 ethernet not working, was previously working prior to installing Ubuntu as dual boot. Ethernet works well in Ubuntu. The solution is simple. Totally unplug power cord, wait a few minutes, boot into Windows. Problem will be gone!

  • Thanks for the help, this does work. However, it's still not a satisfactory solution given that I will need to do this each time I switch OSs – Usagi May 2 '11 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.