6

I am trying to install Ubuntu Touch on my Galaxy Nexus, but it says adbd cannot run as root in production builds. I tried a lot of stuff, including a few instructions from Ask Ubuntu, nothing helps. Can anybody please advise on what can be my problem?

  • 3
    You said you tried "a few instructions" from here. Can you edit your question to include detailed information on exactly what you tried? (Please describe whatever techniques you attempted and link to the posts where you found them.) – Eliah Kagan Mar 6 '13 at 22:55
2

You have to unlock your bootloader. Please follow these steps:

Step 2 - Device unlock

  1. With the device powered off, power on the device by holding the Power button + volume up + volume down.
  2. The device will boot into the bootloader.
  3. Plug the device into the computer via the USB cable.
  4. On your computer, press Ctrl+Alt+T to start a terminal. Type sudo fastboot oem unlock, followed by Enter
  5. On the device screen, accept the terms of unlocking.
  6. Boot the device by pressing the power button (pointed by an arrow with Start on the screen).

Source

Please let us know if this worked.

  • 3
    This didn't do the trick for me. Instead I got a factory reset. Lovely! – user347074 Nov 9 '14 at 14:44
  • 1
    Yes, you may want to mention that this WILL WIPE ALL DATA from the device. This is intentional, as otherwise any phone security could be bypassed by simply unlocking the bootloader and flashing an arbitrary ROM. @sjums - you will know it 'worked' if you see a small 'unlocked lock' icon when your phone is starting up. – Jordan Feb 22 '15 at 20:01
  • What about Settings/System/DeveloperOptions/OEM Unlock? Also, on Pixel, you should use Volume down + Power buttons only. – Vlad May 17 '18 at 22:07
2

You could try this:

adb shell setprop ro.secure 0
adb shell setprop ro.debuggable 1
adb shell setprop persist.service.adb.enable 1
adb root

That may work on some devices. Try it yourself and good luck.

  • This didn't work for me on a rooted LG Lucid 2 – alexgophermix Oct 20 '15 at 0:01
  • This didn't work for me on rooted Google Nexus 5, android version 5.1.1 – Han Qiu Oct 14 at 1:45
1

That error occurs on phone's that have a production build. You need to get an other android distribution. I would recommend cyanogenmod.

But the people on XDA can help your better. Here's a link:

Samsung Galaxy Nexus - on XDA

1

If you are following the instructions at https://wiki.ubuntu.com/Touch/Install, the probable reason for the error is that you're trying to run 'phablet-flash' command without having done the bootstrap 'phablet-flash -b' first.

0

This might help you: adb remount permission denied, but able to access super user in shell — android

In my case I had to flash my nexus4 with cyanogenmod10 in order to be able to install Ubuntu Touch Raring on my device.

Good luck!

0

Although I might be late here, please install the following if your phone is rooted:

http://forum.xda-developers.com/showthread.php?t=1687590

There is a paid version of the above on play store

https://play.google.com/store/apps/details?id=eu.chainfire.adbd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.