2

I am on Ubuntu 12.04. I managed to install the FortiClient after lots of search and mainly by installing everything suggested on these pages :

Now I have it running and the connection status indicates tunnel running and I see bytes receives and send bytes.

I am trying to connect to remote desktop to a Windows 7 machine but it doesn't work. first thing first I check if I ping the machine and no it doesn't ping.

I looked under Devices - Network Tools, I can see that there was no interface created for the VPN and I don't have an IP for the tunnel. I only have my local network IP.

I tried the 2010 and 21467 versions.

Can someone help on this?

1

Ok I found the solution. The forticlient does not create the routes needed for the tunnel to work as expected. In a terminal type:

sudo route add -net [office lan IP] netmask 255.255.254.0 dev ppp0

eg:

sudo route add -net 192.168.38.0 netmask 255.255.254.0 dev ppp0

where 192.168.38.0/23 is my office LAN range. My office PC is on 192.168.38.83. Then when using remmina app I used my office PC IP-Address and got my remote desktop working. My Win7 office PC looks like win XP but at least I can work.

The only problem is that I have to enter this command EACH time I reconnect to the vpn through forticlient.

I added this command in a script in /etc/ppp/ip-up.d but that didn't work.

0

I solved similar issue (on debian 9) by running:

apt-get install ppp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.