I'm using Ubuntu 12.10 64 bits, on a Lenovo Ideapad U410. I've been using the included webcam with Skype and Google Hangout with no issues. At some point in time, I noticed on Google Hangouts some update made the cam stop working.

When I run lsusb, this is the result:

Bus 003 Device 002: ID 04f2:b2e1 Chicony Electronics Co., Ltd

On /dev I see this:

crw-rw----+ 1 root video      81,   0 Mar  5 00:52 video0

Also this:

 ~ $ ls /dev/v4l/by-id/
total 0
lrwxrwxrwx 1 root root 12 Mar  5 00:52 usb-Vimicro_Corp._Lenovo_EasyCamera-video-index0 -> ../../video0

So, now I test something like VLC to "Open Capture Device". The webcam turns on, but there's no image. Same thing on Skype, I test the video and the cam turns on, but no image. At some point, the camera disappears from lsusb and I can't see it there anymore.

I tested Ubuntu 12.10 from a live USB and the camera works perfectly from there, so it's not a hardware issue, but a software issue. I even tried to run Skype as a root user to test if this was a change in permissions issue, but it still doesn't work.

I have no clue as to how to debug this issue, or find whatever update or installation made it stop working.

  • Have you tried creating a new user and use your webcam there? – Mostafa Shahverdy Mar 5 '13 at 12:36
  • Tried that, didn't work. Booting with linux-image-3.5.0-23 fixed the issue. – Fernando Briano Mar 6 '13 at 0:51

I just had a similar issue on a Thinkpad T430u that I was able to fix by booting to an older kernel. It sounds like this could be the same issue since the live USB is probably running an older kernel. I just posted an answer to a similar question, so instead of retyping the whole thing, see here:


If this fixes your issue, please file a bug report or comment on the one I linked to in that answer so the developers know this affects Ubuntu 12.10 as well. Hopefully if enough people report this bug it should get fixed soon.

  • Booting back with linux-image-3.5.0-23 made it work, so yeah, it's a bug in the kernel probably. Thanks for your answer! I've added my comments on the launchpad bug report. – Fernando Briano Mar 6 '13 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.