64

There is no option in Mouse & Touchpad Settings to enable horizontal scrolling in Ubuntu 13.04+ (Raring/Saucy/Trusty) (GNOME 3.8+):

Mouse & Touchpad Settings

No horizontal scrolling even by enabling two finger scroll or content sticks to fingers.

How is it possible?

5 Answers 5

66

There’s a way through dconf Editor; so:

  1. open dconf Editor through the Dash;
  2. go to org > gnome > settings-daemon > peripherals > touchpad;
  3. check horiz-scroll-enabled, as you see in the screenshot.

Enable horizontal scrolling

Edit: Dconf Editor was pre-installed on 13.04, where I first faced the problem; but on 13.10 and 14.04 it’s easier to use gsettings, see Samuel Cavazos’s answer.

8
  • 12
    Thank you! I still don't understand the reason for removing that option from the control panel :/
    – mid_kid
    Commented Apr 16, 2013 at 21:09
  • 4
    Yeah, me too. Seems it’s about GNOME project, where functionality is sacrificed for simplicity! Commented Apr 17, 2013 at 19:10
  • 1
    At least they don't make it impossible ;)
    – mid_kid
    Commented Apr 23, 2013 at 15:37
  • 1
    This is a moment when I wish stackoverflow framework permitted multiple upvotes ;) thanks
    – lu1s
    Commented Jul 23, 2013 at 8:23
  • 3
    What if there is no touchpad key? FYI: My laptop gots touchpad. v16.04 Commented Jan 20, 2017 at 11:34
31

Alternative way: run this in your command line

synclient HorizTwoFingerScroll=1
9
  • Does it enable edge scrolling too if I’ve disabled two-finger scrolling? Commented Aug 29, 2013 at 15:45
  • I think edge scrolling is controlled by other options: VertEdgeScroll and HorizEdgeScroll Commented Jan 18, 2014 at 15:55
  • 4
    Neither dconf editor nor gsettings worked for me on Lubuntu 14.04, but this one did: synclient HorizEdgeScroll=1
    – iynque
    Commented Mar 6, 2015 at 3:08
  • 2
    @iynque Works on Xubuntu 16.04 as well. How do you make this permanent?
    – sanwablo
    Commented Dec 18, 2016 at 11:17
  • I am on Lubuntu 17.04 and i got an error message stating: Couldn't find synaptics properties. No synaptics driver loaded?.
    – kiltek
    Commented Oct 23, 2017 at 6:11
22

Or just run

gsettings set org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled "true"

in a terminal

6
  • This trick also works great if you have the opposite goal: turning the horizontal scroll off. Just set the variable to “false” instead of “true”.
    – Bryson S.
    Commented May 8, 2015 at 0:45
  • It said to set the value of the key. Nothing happened. Commented Jul 5, 2016 at 18:39
  • Ran gsettings set org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled "true" in Terminal, nothing happened. Commented Jul 5, 2016 at 23:33
  • 6
    $ gsettings set org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled "true" > No such schema 'org.gnome.settings-daemon.peripherals.touchpad' Commented Feb 15, 2017 at 21:56
  • 3
    I am on Lubuntu 17.04 and also got the No such schema 'org.gnome.settings-daemon.peripherals.touchpad' message.
    – kiltek
    Commented Oct 23, 2017 at 6:09
9

Configure your Linux key binding to make Shift+Mouse wheel send an horizontal scroll event:

  • Install xbindkeys xautomation

  • Edit ~/.xbindkeysrc.scm and write:

      ; bind shift + vertical scroll to horizontal scroll events
      (xbindkey '(shift "b:4") "xte 'mouseclick 6'")
      (xbindkey '(shift "b:5") "xte 'mouseclick 7'")
    

Run xbindkeys.

Also, for Firefox 17+, open about:config and set:

  • general.autoScroll = true
  • mousewheel.with_shift.action = 1
  • mousewheel.with_shift.action.override_x=1 if on Firefox >= 121 (see the comment)
  • Optionally, configure scroll speed: mousewheel.with_shift.delta_multiplier_x = 300

Source: https://coderwall.com/p/xnez3g/horizontal-scroll-with-mouse-under-linux

I got both working. Although for xbindkeys, some apps stick with their own behavior, for instance Firefox.

5
  • This is fantastic, thank you sooo much, you're the best.
    – zwolin
    Commented Sep 24, 2018 at 18:54
  • 1
    works for me on ubuntu 23.04 Commented Jul 3, 2023 at 14:18
  • stopped working after upgrade to 23.10 :-( Commented Nov 13, 2023 at 10:07
  • the problem with 23.10 is only with firefox and can be fixed by setting mousewheel.with_shift.action = 4 source of knowledge: support.mozilla.org/zu/questions/1358257 Commented Nov 24, 2023 at 8:03
  • after upgrade of Firefox to 121 (wayland is default instead of X), I needed to set also mousewheel.with_shift.action.override_x=1 and then scrolling started to work again Commented Dec 20, 2023 at 18:45
4

On the MATE desktop variant, I found the following dconf path to work:

/org/mate/desktop/peripherals/touchpad/horizontal-two-finger-scrolling

If you do not already have the dconf-editor, you will want to run sudo apt install dconf-editor

Start dconf-editor and then search for "horizontal-two" and that should be specific enough to find it:

Screenshot of changing /org/mate/desktop/peripherals/touchpad/horizontal-two-finger-scrolling setting

I'm using a laptop with a Synaptics touchpad running Ubuntu (MATE) 18.04.

Yonn Trimoreau says that on Cinnamon, the following dconf path should work:

/org/cinnamon/settings-daemon/peripherals/touchpad/horizontal-scrolling

You would install the same dconf-editor, but search for "horizontal-scrolling" and then set it to on.

4
  • 2
    sudo apt install dconf-editor
    – jperelli
    Commented Aug 6, 2019 at 14:25
  • 1
    On Cinnamon: org.cinnamon.settings-daemon.peripherals.touchpad.horizontal-scrolling Commented Apr 15, 2020 at 16:40
  • @YonnTrimoreau took the liberty of editing my answer to include your note. Feel free to edit my answer if you see anything that needs changing or could be improved.
    – Azendale
    Commented Apr 17, 2020 at 15:00
  • Working great on Cinnamon 20.1, upon closing dconf-editor Firefox immediately started scrolling horizontally. Baffles me why the default isn't True. Commented Jun 7, 2021 at 0:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .