15

I know there are a lot of questions about this -- I've read at least 100 questions about it but still can't find a solution to the Nvidia screen flicker issue. I've had this issue since 11.10. The screen jitters and flickers about every 3-5 seconds. I'm running Ubuntu 12.04 LTS on a Gateway GT5028 with the Nvidia 6100. Any solution would be appreciated. I'd like to see this issue resolved for me.

8 Answers 8

9

This worked for me:

  • Install Compiz Config, from a terminal, type:

    sudo apt-get install compizconfig-settings-manager

  • From the launcher, execute CompizConfig Settings Manager

  • Check the checkbox in "Utility -> Workarounds -> Force full screen redraws (buffer swap) on repaint"

I have a Dell XPS laptop with a Nvidia GT 525m, using Ubuntu 14.04.

I base this solution on the answers on this thread: Weird partial screen flickering after upgrade to 14.04

4
  • It worth noting this will considerably increase the load on your gpu&cpu and will cause fps drops.
    – Edward
    Oct 4, 2015 at 12:58
  • Debian 8 and KDE 4 here. What helped me was disabling certain KDE effects in settings.
    – LatinSuD
    Jul 26, 2017 at 14:30
  • Should changes come to effect even without restarting the computer? It seems like nothing is working for me
    – embe
    Jan 2, 2018 at 19:44
  • @embe Looks like a reboot is necessary. Oct 25, 2020 at 19:51
5

Try turning dithering off (disabled) using nvidia-settings. If the problem is resolved, update /etc/X11/xorg.conf to add (Option "FlatPanelProperties" "Dithering=Disabled") to the Screen section. Good luck.

12
  • How to I access the settings? I don't have any nvidia drivers activated right now because everytime I activate one it brings up a black screen on the next start up. I'm able to access TTY when it does this just can't see the desktop. Mar 5, 2013 at 14:11
  • Settings are available via nvidia-settings. If nvidia driver has not been installed, you can either 1) install through system settings->additional drivers, 2) sudo apt-get update;sudo apt-get install nvidia-current nvidia-settings, or 3) download/install the driver directly from nvidia. Everyone has their preference, but I tend to favor the latter. Good luck and have fun. Mar 5, 2013 at 19:09
  • Alright I've installed the nvidia current driver. Thankfully no black screen this time. But I see nothing about dithering in Nvidia X Server Settings Mar 6, 2013 at 4:36
  • The default nvidia-settings does not include the option. If your screen flicker is still an issue, consider downloading the driver from nvidia. You can refer to instructions on this q&a board. Mar 6, 2013 at 11:23
  • Could you give me a quick breakdown on how to edit the settings via command line. Mar 7, 2013 at 14:07
3

Flickering windows under Ubuntu 14.04 fixed - NVIDIA graphic card

I have resolved the problem of flickering windows under Ubuntu 14.04 on my laptop and it is basically a problem related to the Nvidia graphic card setting, start by typing:

sudo nvidia-xconfig

If the file /etc/X11/xorg.conf does not exist, this command will create it.

sudo nano /etc/X11/xorg.conf

Scroll in the file and edit the Device section as follow:

Section Device
  Identifier Device0
  Driver "nvidia"
  VendorName "NVIDIA Corporation"
  BoardName "GeForce GTX 650"
  Option "RegistryDwords" "PerfLevelSrc=0x2222"
  Option "TripleBuffer" "True"
EndSection

Usually the 3 last commades are missed in the section Device. This sets the card to performance mode and enables triple buffering.

In the terminal type:

nvidia-settings

and the X-server will appear Set argument's values in nvidia-settings/OpenGL as follow:

Sync to Vblank
Allow Flipping
Use Conformant Texture Clamping

Save the configuration and then restart the computer.

3
  • How do you save the configuration?
    – Aaron Esau
    Jan 23, 2017 at 2:29
  • Amazingly, installing nvidia-settings actually fixed everything.
    – Blairg23
    Sep 13, 2017 at 5:38
  • I do not see an "OpenGL" option anywhere in the interface: imgur.com/y4ueF6m.png Also, doing sudo nvidia-xconfig results in a black screen. Oct 26, 2020 at 13:50
2

I had the same problem. You are confused because cogitoergosum assumed that you understand how the command line works. You will need to open a command prompt, and you will need to learn how to use several commands. The only way to truly solve this problem requires working on the command line interface (CLI). CLI skills are extremely valuable, especially in professional computing; so I will help you get started.

First, type man cd and press enter. To escape the manual pages, when you are done reading and want to try out the command cd, type q. On Linux, unlike Windows, man + [command] will bring up the manual pages for any command you desire (just replace the + [command] with your desired command. For example, type man vi to learn how to edit files with vi.

cd /etc/X11/ will take you to the directory containing "xorg.conf". You need to be careful to fix changes to the ownership and permissions of the files when they are edited as the root user.See the man pages for chmod and chown (type man chmod or man chown). You will always want to backup your files before changing them. To backup files, there are a few techniques. You can use cat to output a file's contents and then redirect the output to a new file. Eg. cat /etc/X11/xorg.conf > /etc/X11/xorg.conf.bkp1. You can also use cp or mv, but I usually just use redirection. To see a given directory contents, try ls or ls -l. If you can't see all the output, pipe the output into less by typing ls -l | less.

I found the solution to Nvidia bugs on Linux here for 64 bit: Nvidia & Linux x64 - common problems and solutions Readme - Here's the same readme for 32 bit (x86): Nvidia & Linux x86 - common problems and solutions Readme - 256.44 If you are using different Nvidia drivers for Linux, then you can find similar readme files on the Nvidia site here: Linux Display Driver Archive.

If you really want to increase your skills, you should Google the linux documents on shell scripting.

1
  • 3
    This seems extremely off-topic and irrelevant. The information is great, everyone needs to know it... but you failed to even attempt to treat the OP as a non-newb. You assumed the OP assumed, then plunged right into a lecture. Jun 5, 2015 at 23:01
2

Just for all the others having this problem. Turning off dithering in nvidia settings appeared to have reduce the effect but it wasn't totally gone.

But turning off Flipping helped. I don't have this nasty flickering anymore. Yay!

How to do it on linux mint 18.3 cinnamon with an installed nvidia driver (nvidia-384 Version 384.111-0ubuntu0.16.04.1):

  • Open your application menu
  • Search "nvidia": You'll find "NVIDIA X Server Settings" – click that
  • Turn off Dithering: I found it under GPU 0 – (your GeForce name) -> DFP-0 (your monitor name) (and DFP-3 & DFP-4, as I have 3 monitors)
  • Turn off Flipping: X Screen 0 -> OpenGL Settings -> Allow Flipping (uncheck)
3
  • +1 turning off Flipping helped!
    – Ben
    Nov 15, 2018 at 13:27
  • This worked, but how to make my changes persistent? After reboot, all changed settings are gone...
    – Ben
    Nov 16, 2018 at 15:41
  • 1
    To save, go to X Server Display Configuration in NVIDIA Settings. Click Save to X Configuration File. @Thomas Praxl: huge thanks! Your solution actually helped me solve color flickering. I knew it was dithering issue I just didn't know where was the option in the menu! Voted your post up!
    – dsolaris
    Jun 11 at 12:26
1

For what it's worth, I've been having this screen flicker issue on my Ubuntu/Debian-based MythTV box for years. I had it on 14.04 and I just recently upgraded that box from Linux Mint 18, where the problem also existed. I'm now running 16.04.2. The compizconfig-settings-manager change to force redraws did not work for me, but it got me playing around with the other settings. What fixed it for me was unchecking the "Force complete redraw on initial damage" option.

I don't know if I have a hardware issue that is causing a bit to be flipped which Compiz thinks is damage, but I haven't seen any artifacting or damage and the screen flicker is gone. I'm using the Intel embedded graphics in my Pentium G870 over HDMI to a 1080p TV.

0

Im using Linux Mint 17 with same issues plagued for some time. Discovered through linux software manager you can just type nvidia in the search bar (as in my case) "graphics" related of course and click on; Nvidia-Current-Updates. Once installed problem was resolved and performance when up. According to Nvidia website - linux software manager there are 26M drivers the program manager will analyze and download the specific driver. My problem has been solved.

1
  • Answers rooted in special tools from Linux Mint are not compatible with AskUbuntu as Ubuntu does not possess those tools. Nov 7, 2014 at 3:18
0

This is what worked on my Ubuntu 20.04 system with an Nvidia Quadro K2000M card and the recommended 390 driver:

cat /usr/share/X11/xorg.conf.d/10-nvidia.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

Add Option "TripleBuffer" "TRUE"

sudo nano /usr/share/X11/xorg.conf.d/10-nvidia.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "TripleBuffer" "TRUE"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

reboot

Background

The screen on my laptop started flickering a few days ago. I had been running Ubuntu 18.04 and 20.04 without issue. I spent about two days researching this, but nothing worked.

My system doesn't have an /etc/X11/xorg.conf file. Many of the settings discussed in the nvidia-settings program no longer exist. The nvidia-xconfig program produces an xorg.conf file that appears to be obsolete. Even Nvidia's documentation at http://us.download.nvidia.com/XFree86/Linux-x86_64/319.32/README/xconfigoptions.html doesn't mention the new Xorg configuration sections.

2
  • My God, it looks like this definitely works on Kubuntu 20.04 for me. My Nvidia card is a GeForce GTX 1050 Ti.
    – cnobile
    Mar 1, 2021 at 20:38
  • Well, this kind of worked. The flickering is greatly reduced.
    – cnobile
    Mar 3, 2021 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.