1

This topic seems to have been covered quite heavily within these forums but there doesn't seem to be any trend from what I've read so far so I'm just looking to for some starting points to help troubleshoot.

I have thin client booting successfully over DHCP. All looks good and the screen with the flashing dots appears leading me into thinking that I'm about to see the expected log-in screen. However, all that transpires is a blank, black screen - that's it! No error(s)! Nothing! I've changed my pxelinux.cfg/default file and removed "quiet splash" and restarted the thin client. Still nothing useful is presenting itself. My assumption at this point is that this is not an DHCP issue.

Thanks, DJC

  • An update on this.. I gave up on this to a degree. Instead, to ensure that the actual thin client/DHCP concept was working I altered my lts.conf file so that the client will not attempt to launch X/LDM. Success!! That worked great. I can now see and use a prompt on my thin client. However, the problem I was originally experiencing must be related to X/LDM because as soon as I type startx, I witness my initial problem (black screen - boooo). I thought no problem, the related error must be logged somewhere under /var/log but that doesn't seem to be the case. Any idea where they are? – DJC Mar 6 '13 at 15:36
0

it's been a while since your post, but did you look at the host of options available here: http://manpages.ubuntu.com/manpages/precise/man5/lts.conf.5.html

You can set your screen, card and other options in detail.

Also, you can see in your server's /var/log/syslog what happens as soon as your client has booted and connects to the server in a session. Even the DCHP event and pxe (if you boot using that) will show it, if you set logging to debug or something similar.

The logging you're looking for actually happens on the thin client, not on the LTSP server. When you create the image that boots the thin client (in chroot), you can add a user and allow it to log into the thin client. Also install sshd and make sure it's listening. There are more examples of this out there, but here's one to start with: Add user to LTSP chroot for troubleshooting

If you did manage to solve the issue in the meantime, do give us an update here please.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.