I am trying to install Meshlab as per the documentation. I installed all the dependencies and followed the steps. But am having trouble with certain steps here.

  • In order to successfully compile a MeshLab's plugin with external dependency you have before to compile the referred library and put it into the folder ~/devel/meshlab/src/external/lib/YOUR_DEVELOPMENT_ENVIRONMENT where YOUR_DEVELOPMENT_ENVIRONMENT is a string related to your operating system and compiler's version.

I am using Ubuntu 11.10 and gcc, qmake. I do not know what is the exact value of the string I have to give for YOUR_DEVELOPMENT_ENVIRONMENT. I tried to go through qmake guide and qmakespec definitions. It said it would actually lead to a path.

As per this link, for Ubuntu 10.04, he has given the value as linux-gcc. Can you please tell me what value I should give?

  • I tried to compile the meshlab_mini.pro, which doesn't not need the external libraries, but got this error.

     /usr/bin/ld: cannot find -ljhead

I do not know how to proceed after this. Please help me here.


I tried to compile meshlab_full but I hit an error. It seams like, you have to compile the external dependencies first! -> Meshlab (So go to meshlab/src/external/ and compile external.pro)

I tried to compile the meshlab_mini.pro, which doesn't need the external libraries, but got this error.

I think thats not right..

jhead ( http://www.sentex.net/~mwandel/jhead ), absolutely required. It's needed by MeshLab main application. In order to compile it, please read in the following lines how to compile MeshLab's external libraries.

  • I wasn't able to resolve this, So just installed it from Synaptic Package Manager. – Lakshmi Narayanan Apr 12 '13 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.