I'm having no luck at all with this iPod Nano.

I've tried the following software:

  • Banshee - The iPod shows up and files seem to be copied, but they don't show up on the iPod.
  • Rhythmbox - Same as Banshee. Claims to sync but no files available on the iPod
  • gPodder - At first it wouldn't even recognize the device even though I set the mount point and device type. After syncing one file to the iPod from iTunes on my mac it now behaves as Banshee and Rythmbox.
  • gtkpod - Again: Copies the files but they are inacessible on the iPod.
  • Hipo - Doesn't even recognize the iPod
  • Amarok - What is this, I don't even...

So to summarize: After some fiddling I can get most of these apps to recognize the iPod and copy files to it, but they are not accessible on the iPod which sort of defeats the whole purpose.

Help me out here. My continued harmonic love life depends on it. (Yes, it's the girlfriends iPod and laptop)

  • rhytmbox has support for the ipod, i think. Jan 28 '11 at 7:56
  • askubuntu.com/q/27141/10698 This question may help to why your iPod isn't showing up.
    – Alvar
    Nov 23 '11 at 18:09
  • 1
    any updates for ubuntu 12.04?
    – waspinator
    Jun 2 '12 at 0:26
  • iPod nano still doesn't work for some Ubuntu and there are a couple of bug asking for this to be solved.
    – Braiam
    Feb 23 '14 at 0:02
  • 1
    I don't think this should have be closed, because it's specifically about the Nano 6g, which has a different architecture to most (all?) other iPods. It is identified by an 8-byte hash, as opposed to the 20-byte hash of other iPods. In addition, this is the solution. It is an inappropriate answer to the duped question, because it only applies to the Nano 6g.
    – Sparhawk
    May 17 '18 at 7:17

12 Answers 12


Apparently Apple borked linux support with Nano 6g, and it's proven difficult to hack the music database to allow access to non-iTunes apps.



  • 2
    Crudmuffins. I'll just have to keep an eye on the development here then.
    – Martin
    Feb 15 '11 at 7:27
  • 1
    Keep an eye out on gktpod's development. They should be the first to implement it when it's possible.
    – MarkovCh1
    Jul 24 '11 at 23:14
  • 1
    Are there any updates about the iPod Nano 6G? Feb 26 '12 at 16:12
  • gtkpod.org/wiki/Home says 6g works with a binary blob.
    – idbrii
    Jul 26 '15 at 18:37

I had the same problem and fixed it with the sledgehammer method:

Virtual Windows system + ITunes.

I installed virtualbox 4 and set up a Windows XP. To use the USB drivers I installed the Oracle Expansion Pack. The Licence changes from OSE (Open Source Edition) to PUEL (Personal Use and Evaluation License).

Plugin the Ipod to your Ubuntu System. Start the VM with Windows and Itunes. Under "Devices" in the Virtual Box select your ipod nano. Windows and Itunes will find it.

I also shared my music-library with a virtualbox shared folder and mountet it under windows.

This works for me but I am unhappy with the situation too.


I just tried the solution, syzygy proposed: I installed the Spotify client preview for Linux and synced my iPod Nano 6G with it. So far it works.

Be aware that first Spotify wipes the iPod and then gives you the possibility to sync playlists. Spotify doesn't have the same comfort as Rhythmbox or Banshee yet, but I am happy that there is finally a solution for the iPod Nano 6G.

This works with a free account.


I've been running into the same problem. The gtkpod website specifically says that the iPod Nano 6G is not supported by libgpod yet.

Unfortunately a whole bunch of ipod syncing software uses libgpod as a sort of base. and so far that isn't an easy hack for it either. most sites i found talking about talking about jailbreaking the 6G offer a long and painful process with little to no useful results for the average user.

It looks like at this point we have to wait until someone smarter comes along and comes up with a practical solution.

Or sell your nano and buy an older model....


I figured out to use it in Banshee in Ubuntu 12.04 in 32 bits.

  1. Install libgpod4_0.8.2 and libgpod-common_0.8.2 from http://franck78.ath.cx/

  2. Downloaded libhashab.so and in root mode place it in /usr/lib/libgpod and put all permisions to read and write.

That's it


gtkpod , Banshee, and Rhythmbox do not support this player. Put a virtual machine with windows 7 for ITunes.


You can use spotify. They have a very nice linux version. The only problem is that you can only get it with the 5 dollar a month account but it is totally worth it!


I am not sure that this works, and you will certainly have to reset your iPod in iTunes so that you unlock syncing (you can only officially sync with one computer), but Spotify has iPod syncing.


I own the iPod 6G Nano as well. Unfortunately there is no linux support for it as of yet (even in 12.04). The only solution would be either run Windows in a Virtual Box with iTunes or maybe iTunes 10 under WINE


Spotify for Linux will now work with a Free account (as of October) so it is THE solution to manage (sync) your music simply within Ubuntu.

Works with Lucid 32bit (and earlier versions I guess). Not tested with 64bit

  • This is not available for users outside US. So there is still no posibility i guess... Feb 18 '12 at 22:56
  • You can't even install it outside the US, to use with local files? :(
    – MarkovCh1
    Apr 3 '12 at 2:05

Have you looked into installing iTunes? Install Playonlinux and they have Itunes 10. It's really simple to download and use. I have not tried this, but it should work gl!



gtkpod provides a graphical user interface that enables users of Linux and other Unix operating systems to transfer audio files onto their iPod Classic, iPod Nano, iPod Shuffle, iPod Photo, or iPod Mini music players. Although it does not support some of the more advanced features of iTunes, gtkpod still performs the role of an iPod manager for Linux. Album art and videos are now supported, and preliminary support for jailbroken iPhones and iPod Touches is available.

Its available to install from the Ubuntu Software Centre


Not the answer you're looking for? Browse other questions tagged or ask your own question.