10

Hey my wifi keeps prompting for the WPA2 password. Is there something that I need to do with Network Manager?

Linux version 3.5.0-17-generic (buildd@roseapple) (gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1) )

Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal

Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
5
  • 1
    Eeeh. Just click remember password?
    – Melon
    Mar 3, 2013 at 18:28
  • Yeah its saved and will stay connected for a little while but ask for password again.
    – 24hrEnErGy
    Mar 3, 2013 at 19:29
  • Hm. Do you use torrent? I had similar thing. My WiFi router got down any time I downloaded torrents. Maybe it's the same thing here?
    – Melon
    Mar 3, 2013 at 21:46
  • No trorrent, pretty much just the default install package. Anyone know where all controls the wifi by default and where logs are kept.
    – 24hrEnErGy
    Mar 3, 2013 at 23:18
  • Do you mean that you can connect to the WiFi network just fine, but it keeps wanting to pop up a dialog for the password except with the password already filled in? This keeps happening for me on one specific network. (Which happens to be our new home WiFi network, making this really annoying. We moved about a month ago, and the CenturyLink tech gave us a new router/modem combo. Our old router was from the 802.11n draft days.) It usually happens when it reconnects to the WiFi after opening the laptop lid, but sometimes it doesn't, and the other day it kept doing it intermittently with it open. May 19, 2015 at 2:21

8 Answers 8

3

below thing solved mine

sudo vim /etc/NetworkManager/system-connections/ConnectionName
set this : password-flags=0

next time this will store your password.

2

Seems to be a duplicate of Network manager forgets wireless password after sleeping or powering off

You might find it useful to set the connection as "available to all users", or remove duplicate connection configs for the same wifi

also, it's probably related to this known bug

1
  • what do you mean by "same" in "the same wifi"? Do different access-points on the same wireless radio count as "same"? Feb 9, 2015 at 17:30
1

This usually fixing that issue with your device it changes the encryption from hardware to software.

Run the commands one line at a time, just copy and paste for accuracy.

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

sudo modprobe -rfv ath9k

sudo modprobe -v ath9k

Thanks

1
  • Not tried this, but do you have any reference for this? thanks
    – dashesy
    Dec 5, 2013 at 19:29
0

I know it sounds strange but I have the experience that in a case like this it might help to reboot your router.

Also check if the packet "wpasupplicant" is installed.

0

You need to explicitly call the dhclient and make it assign your wifi an IP.

sudo dhclient wlan0.

This works on Ubuntu 14.04.

5
  • DHCP errors aren't the cause of the need for re-authentication. Oct 20, 2015 at 0:11
  • My guess, why it kept asking was because it could not get an IP. That's why I suggested. I had the same issue on my Ubuntu. It worked with this.
    – deerishi
    Oct 20, 2015 at 0:13
  • If it can't get an IP address, it shouldn't ask for the password. It'll just auto-assign one. Oct 20, 2015 at 0:14
  • What are saying makes sense, but then how did it get working after command?
    – deerishi
    Oct 20, 2015 at 0:24
  • 1
    I'm not sure, but also remember you're 2 years late on this answer and two major versions ahead of the OP. 12.04 may be different. Oct 20, 2015 at 0:26
0

The problem may be that netctl is still controlling your network connection. This worked for me

# systemctl disable netctl-auto@[interface_name].service

You may also have to run the "systemctl stop" command for this as well.

0

try changing the name and password of router,so that PC identifies it as a new network. Then connect to it. It works for me.

0
PROBLEM : Rtl8197 wifi card on Toshiba Sattalite L40 R18 keeps asking password for WPA-WPA2
- Activated second wireless with WEP did not work with 801.11n standard. Not connected.
- Activated second wireless without security. Not connected.
- Changed 801.11n to 801.11b (11Mpbs). Connected
- Upped to 801.11b (54Mbs).Connected
- Upped to 801.11g (300Mbs).Connected 
- Removed second wireless SSID. Attempted to original SSID. Connected 
SOLVED.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.