29

I have the message:

Error Broken count >0
Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f
Details: The following packages have unmet dependencies:
firefox-globalmenu: Depends: firefox (= 19.0+build1-0ubuntu0.12.04.2) but 19.0+build1-0ubuntu0.12.04.1 is installed

Any suggestions?

0
29

Just click on forbidden Icon on top bar, select "Show updates" and follow screen instructions:

enter image description here

by right-click on it, this error message written in it:

An error occurred, please run Package Manager from the right-click menu or apt-get in a teminal to see what is wrong. The error message was :'Error:BrokenCount>0'. This usually means that your installed packages have unment dependences

Also you can use command instead: sudo apt-get install --fix-broken

1
  • This fixed my problem. I was able to locate exactly what package was causing the trouble and removed it. Then problem solved.
    – Ébe Isaac
    Jun 29 '16 at 6:24
21

As the message says, you might have bad repositories. You can either remove them, or remove all repositories and only keep the default ones.

Run:

gksu software-properties-gtk

This will open the software sources dialog. Click on "Other Software" and remove all third party repositories.

will be like this

After that, run this command and see if the problem has been solved:

sudo apt-get update && sudo apt-get install -f && sudo apt-get update
2
  • 1
    Mahmoud20070 thanks. I think the problem is solved!
    – Perry
    Mar 3 '13 at 23:49
  • answer fixed my problem u a star
    – humphrey
    Sep 5 '17 at 3:00
2

Run this in the terminal

This solved the issue

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

If you have installed Synaptic Package manager then simply filter the broken packages and mark for complete removal. And then hit apply!

0

Open a Terminal and type sudo apt-get upgrade. Check if you see an error similar to:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a'
to correct the problem. 

It means that the upgrade was halted midway. You need to complete the upgrade manually by typing the following commands:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get update && sudo apt-get upgrade

If the error is something like:

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/) is another process using it? 

In this case, the upgrade process was unable to remove its lock file before exiting. Let's remove the lock files and try again:

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock

Now, type:

sudo apt-get update
sudo apt-get upgrade

That's it. You should be good to go now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.