I'm getting a message:

kvm:disabled by bios

after upgrading my kernel to 3.8.x. I've never installed the KVM package. Neither I can enable virtualization from my BIOS, because of a BIOS bug. I just want to get rid of this weird message. Tried removing any kernel module using modprobe but it didn't work.

  • 2
    I don't agree that this is a duplicate. This question specifically asks how to suppress the message given that the BIOS arbitrarily disables virtualisation, and is focused on keeping virtualisation disabled. The other question is (implicitly) asking how to enable virtualisation, with the error message being a symptom of the problem, rather than the problem itself. So although I agree that the questions are related, I don't think they're the same. In fact, they might even be considered opposites. – Robie Basak Aug 13 '13 at 22:59
  • It's not a dupe but it is a question seeking a workaround for a bug and so should be closed as off-topic instead. – Tom Brossman Aug 14 '13 at 10:19
  • 2
    It's a BIOS bug, not an Ubuntu bug, for which a workaround is being sought. I don't think this fits with the spirit of the off-topicness of bugs, since a BIOS bug doesn't generally belong on Launchpad either, really. – Robie Basak Aug 14 '13 at 12:02
  • @RobieBasak we do not care who's fault is the bug, it's a bug and needs to be fixed by the one that develops them. Is simple. If the bug-tracker isn't LP then look for it, bugs are bugs and hence off-topic independently what part of the software/hardware/firmware has it. – Braiam Dec 2 '13 at 18:01
  • It's not even a bug. Many BIOSes intentionally ship without any way to enable VT. – Alistair Buxton Dec 2 '13 at 18:33

Create a file called /etc/modprobe.d/blacklist-kvm.conf:
(For example, you can use gedit gksu gedit /etc/modprobe.d/blacklist-kvm.conf or nano sudo nano /etc/modprobe.d/blacklist-kvm.conf)

Put in it the following three lines:

blacklist kvm
blacklist kvm_intel
blacklist kvm_amd

I'm not sure if this will work for you, because I don't have a suitable system also disabled by BIOS. But this is a reasonable way of disabling KVM on Debian or Ubuntu, so you should try and see if it also works to disable your message.

| improve this answer | |
  • Worked for me on OpenSuse Leap 42.2. Just run mkinitrd after editing /etc/modprobe.d/50-blacklist.conf – lostiniceland Jan 31 '17 at 20:09

What worked for me:

1) Turn on the computer and press f2 to see the setup (BIOS) when you see a screen with black background.

2) Go to "Configuration" tab.

3) Select the option "Intel Virtual Technology" and enable it by pressing F5 or F6.

4) Press F10 to save and exit. When a prompt message appears asking you to confirm this action, select yes.

5) Your computer will turn off for 10 seconds. Then, it will boot and load your OS without showing that error.

| improve this answer | |
  • 4
    actually enabling it seems like a better solution (rather than just hiding the error message)! – hayd Apr 18 '14 at 3:19
  • @hayd: Thanks for your comment. As you said, it is a different way for approaching the same problem. – pablofiumara Apr 19 '14 at 21:56
  • 1
    KVM requires that the virtual machine host's processor has virtualization support (named VT-x for Intel processors and AMD-V for AMD processors). You can check whether your processor supports hardware virtualization with the following command: $ egrep --color=auto 'vmx|svm|0xc0f' /proc/cpuinfo – The Demz Feb 5 '16 at 5:22
  • 1
    This is certainly better than hiding the error. I had the same problem with my Arch installation and enabling Intel VT in the BIOS resolved this error. – Ébe Isaac Mar 23 '18 at 6:22

First of all, you might want to see if KVM is loaded in the kernel. To do this, run something like this:

lsmod | grep kvm

If you do get any answer from that, you may want to stop kvm from running. To do that, this will help:

modprobe -r kvm

Remember to follow for any other kvm module. In my case, there is also a kvm_intel module, so I also have to run

modprobe -r kvm_intel

To stop kvm from being enabled at boot time you have to find the file located at /etc/modules and modify it so that KVM doesn't launch at boot time. After you modify your /etc/modules file restart your computer and see if the problem persists.

| improve this answer | |

You can either remove kvm

sudo apt-get purge qemu-kvm

or ignore that message, it is not hurting anything.

Perhaps there is a bios update available ?

| improve this answer | |
  • 4
    This breaks vmware – notbad.jpeg Jun 28 '13 at 19:47
  • "ignore the message" is not an answer to the question (the OP doesn't want to keep ignoring it). – isomorphismes Jul 21 '15 at 17:04
  • @isomorphismes which is why the first option - remove KVM. the kvm kernel module conflicts with the vmware module. You might be able to manually load/unload the kernel modules, I am not sure with vmware. – Panther Jul 21 '15 at 17:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.