I followed instructions to install nvidia drivers found here: Nvidia driver doesn't work in 12.10 But it doesn't work for me. Same problem like in the question above: no dash and windows don't have borders.

I tried opening nvidia-xsetting, which asked me to run nvidia-xconfig. Running that did nothing but generate a broken xorg.conf which I had to remove because of really low resolution. I thought this is "unity not loading problem" but instead this seems to be "driver not loading problem" because nvidia-xsetting said that I don't use nvidia drivers (which btw I find really weird because lsmod says nvidia kernel module is indeed loaded), and games didn't load either.

I can "fix" this by doing modprobe nouveau, but with nouveau 3D games like 0 A.D. are broken.

Any ideas? I'm out of them.

up vote 0 down vote accepted

I solved it. Problem was that nvidia cards for notebooks (I got geforce 635M) require bumblebee:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-headers-generic bumblebee bumblebee-nvidia
sudo reboot

After reboot run your games ( 0ad for example ) like this:

optirun 0ad

Works like charm.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.