1

I reinstalled gnome-power-manager, upower and indicator-power in order to fix battery indicator issues. Now when I try to login, the screen turns black and sends me back to the login screen.

Following doesn't work for me:

  • Already tried to login with gdm.
  • Removing ~/.Xauthority didn't work either.

I am running Ubuntu 12.04 LTS 64-bit, and don't know what else I can try.

  • Can you login on the console? (via ctrl-alt-f1) – lizifox Mar 2 '13 at 11:40
  • Yes that is working – Benjamin Mar 2 '13 at 11:52
  • I tried apt-get clean and apt-get autoclean and now get Failed to load session "ubuntu" after login. Console is still working. – Benjamin Mar 2 '13 at 16:51
  • I was able to login again after apt-get install unity-2d and apt-get install ubuntu-desktop. Then to make unity start again I ran setsid unity. But now the system icon on the right top is missing. – Benjamin Mar 2 '13 at 17:36
1

The solution is:

  1. Press Alt+Ctrl+F1 to go to the command line
  2. Perform apt-get clean and reboot with sudo reboot
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.