My Adobe Flash plugin has stopped working on Ubuntu 12.04. I cannot see any videos. When I try to install it again, the following things appear on my terminal:

root@ubuntu:/home/salty# sudo apt-get install adobe-flashplugin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package adobe-flashplugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'adobe-flashplugin' has no installation candidate

What should I do now?

  • There is a mistake in the third line. It should say: sudo apt-get install flashplugin-installer (I can't add comments because I don't have at least 50 reputation, so I wrote it as an answer.) – laur34 Sep 6 '14 at 14:33

Open the file /etc/apt/sources.list with a text editor. Uncomment (Remove the preceeding #) on the lines:

deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

In Ubuntu 16.04, this worked:

deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

In the terminal, run

sudo apt-get update
sudo apt-get install adobe-flashplugin

Installation steps of flash plugins

Step 1: Add following line in sources.list (sudo nano /etc/apt/sources.list)

   deb http://security.ubuntu.com/ubuntu lucid-security main multiverse

Step 2: Update apt-get

   sudo apt-get update

Step 3: install flash-plugin

   sudo apt-get install flashplugin-installer
  • This finally worked on 14.04 LTS. Thanks – John Mar 3 '15 at 10:57


sudo apt-get update && sudo apt-get ugrade && sudo apt-get install flashplugin-installer

After that, you should have a functional Flash for your browser.

And please don't work as root! Do the commands given from your normal user account.

  • root@ubuntu:/home/salty# sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. root@ubuntu:/home/salty# sudo apt-get flashplugin-installer E: Invalid operation flashplugin-installer – Lovely Sinha Mar 2 '13 at 9:55
  • 1
    Try from a normal user account. You should not be using root. – user25656 Mar 2 '13 at 9:57
  • @LovelySinha de exit command to return normal user – Thomas15v Mar 2 '13 at 11:40

flashplugin-installer is for the 32-bit version.

On 64-bit you should use adobe-flashplugin! This article has the solution:

  1. Open Software & Updates
  2. Go to Other Software
  3. Select the two Canonical Partners options
  4. sudo apt-get update
  5. sudo apt-get purge adobe-flash{plugin,-properties-gtk}
  6. sudo apt-get install adobe-flashplugin

I've tested this on Ubuntu 14.04 64-bit.


In Ubuntu 16.04 this worked for me:

$ sudo vi /etc/apt/sources.list

     48 deb http://archive.canonical.com/ubuntu xenial partner
     49 deb-src http://archive.canonical.com/ubuntu xenial partner

$ sudo apt-get update
$ sudo apt-get install adobe-flashplugin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.