5

The title says it all. I am in a university which has authenticated proxy. Wine is not detecting this. Hence, none of the applications inside wine is getting internet connection. Please help.

4

I'm struggling with this as well, funnily enough. This is what I've worked out so far:

Wine will grab proxy settings from the environment variable "http_proxy". If you're planning on using the same proxy settings throughout the entire session, you can change the http_proxy variable. Follow these instructions: https://askubuntu.com/a/151047/142903

If, like me, you use the computer on more than one network, one of which has a proxy and one of which doesn't, things get a little trickier. Do all processes inherit environment variables from ~/.bashrc?

NB: You may find it useful to use Gnome or KDE, both of which have graphical interfaces for modifying proxy settings.

Edit #2: After a LOT of digging, I finally found this article on BRAMP.NET describing how to use iptables to redirect all outgoing web traffic on port 80 through a proxy server. The writer mentions that if directly sending the packets to the server doesn't work, it is possible to set up a local proxy server using something like Squid that will point to the network proxy.

This should work for applications that don't respect the http_environment variables. I'm currently working out whether this will still work in 12.04/12.10/13.04, and how to have it done automatically using a script inside /etc/network/if-up.d.

Edit #3: Even more digging has led me to this wonderful post describing how to redirect all system traffic through a SOCKS5 proxy set up by Redsocks - this may be adaptable to suit the current problem.

3
  • I tried the 'http_proxy' thing. I even tried changing some windows registry settings inside wine. Yes I have the tricky situation you have mentioned, and I have not yet solved it :) – dineshdileep Mar 25 '13 at 5:25
  • Are you running Unity? Does the "Apply System - Wide" button in System Settings > Network affect wine? – Blaine Rogers Mar 27 '13 at 20:34
  • I don't think so... – dineshdileep Mar 28 '13 at 4:28
2

Neither setting http_proxy (and HTTP_PROXY) nor using the regedit trick made it work for me. However, using a socksifier helps. Simply install tsocks (or tsocks:i386 in case you have a 32bit wine in use for the program you want to use), configure /etc/tsocks.conf for your proxy server, and export LD_PRELOAD=/usr/lib/libtsocks.so before running wine (e.g. in your .bashrc).

1

As Wine is emulating a Windows environment to let you run Windows application on Linux, this is over the mechanism used by these applications to go to the Internet that you have to look.

Or there is a dedicated set of setting in the application itself to enter the proxy parameters (IP, port, username and password).

Or the application retrieve the proxy settings from the installed and configured Microsoft Internet Explorer. Windows components like Internet Explorer can be installed easily using the winetricks application.

1

You can check Internet Settings by running:

wine rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl

or Wine Internet Explorer by:

wine iexplore

but I don't think you can change the proxy there, unless you'll try to install the standalone web browser which would support that (e.g. MS IExplorer, Firefox or Opera).

However the workaround is to set-up proxy directly in registry:

wine regedit

and change the key in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings by setting ProxyEnable to 1 and specifying ProxyServer address.

Or run the following command:

cat << EOF > proxy.reg
Regedit4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MigrateProxy"=dword:00000001
"ProxyEnable"=dword:00000001
"ProxyHttp1.1"=dword:00000000
"ProxyServer"="http://ProxyServername:80"
"ProxyOverride"="<local>"
EOF
wine regedit proxy.reg

to set-up automatically (change ProxyServername with appropriate hostname).

Source: How do I configure proxy for IE that runs on Wine? at Quora

2
  • yes don't work at all – eusoubrasileiro May 17 '17 at 22:01
  • 1
    I've tried just adding using the registry option, and setting Proxy Enable to 1 and setting ProxyServer (you have to create it) with full url localhost:port did worked. Now i can trace programs that uses the iexplore component. Thanks. – m3nda Jul 14 '17 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.