After running the an update from the update-manager I tried to install chromium:

sudo apt-get install chromium-browser

And I got the following error (full output from `sudo apt-get update' on Ubuntu Pastebin):

Reading package lists... Error!
E: Malformed 2nd word in the Status line
E: Error occurred while processing curl (UsePackage3)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

Working from this answer I guessed there was something wrong with my MergeList. So per the top answer, I removed the Merge List.

 sudo rm /var/lib/apt/lists/* -vf

Then I attempted an update.

 sudo apt-get update

And got the same set of error messages.

My next thought was that one of the repos I had added was faulty in some manner. /etc/apt/sources.list was full on Canonical sources and nothing else. etc/apt/sources.list.d had a few 3rd party sources I had added (namely heroku and Chris Lea's node.js). Just in case I cleared out that directory with sudo rm *. Then deleted the MergeList, and attempted an update. Same error.

What might be causing this set of errors and how do I correct it?

marked as duplicate by Takkat, Eric Carvalho, hhlp, Kevin Bowen, user25656 Mar 21 '13 at 18:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please, upload the output that you get after do sudo apt-get update in paste.ubuntu.com and link it in your question editing it. Also, have you read the comment of that answer? – Lucio Mar 1 '13 at 16:16
  • output from sudo apt-get update is on paste.ubuntu.com. As for the comment I've deleted the MergeList at least dozen times at this point. – nelsonda Mar 1 '13 at 16:24
  • Try with this answer, if you didn't yet. – Lucio Mar 1 '13 at 16:32
  • yes yes, you hadn't posted your comment when I said that but somehow we commented at the same time :D. I have to remove it I guess. – Soroosh129 Mar 1 '13 at 16:38
  • Replacing status with status-old did the job. Thanks to both of you. One last etiquette question though: Should I close this question or answer it myself with a link to the correct answer? – nelsonda Mar 1 '13 at 16:47

It appears that /var/lib/dpkg/status got corrupted. The solution was to restore from /var/lib/dpkg/status-old. Before you do that though, read the full answer.

Thanks to Lucio and Soroosh129 for pointing me to the solution.

Not the answer you're looking for? Browse other questions tagged or ask your own question.