14

I have an Asus Zenbook UX31A, the Asus 13" unit from first generation ultrabooks. I run Ubuntu 12.10 up to date on it.

Before a week or two I used to enjoy more that 5 hours of battery life, especially when watching movies with VLC and hardware accelerated playback. I can't link my issue to some update I did but for several days now and after about 2 to 3 hours, my laptop shutdown abruptly without warning for critical nor low battery level.

I suspect this is battery related since the battery charge curve show that the battery charge plummets from 50-40% to 0% before the shutdowns. Upon reboot, I have to run a "killall Xorg" since the greeter won't load and drop me to something like a black console with lines about battery I can't remember on top of my head right now and an arrow cursor.

After a while, usually 1 to 3 minutes, the laptop shutdown again.

I can't pinpoint the component that cause this. I know it's a software problem since after such an event I can't run it for at least 1h30 in Windows without issues. I lost patience after that but it reported still 1h of autonomy when I powered it off.

Any hint on how to solve or at least identify the culprit ? Any log I can check maybe ?

Thanks.

9
  • Do you get any issues in Windows as well?
    – Wilf
    May 28, 2015 at 9:05
  • you might also, if you're tchnically inclined. remove the battery, boot, clean shutdown, reinstall the battery, boot and test further as this has worked in the past for me to get accurate readings on my laptop batteries just make sure to check accuracy against what windows determines your battery charge to be May 28, 2015 at 20:28
  • It would be helpful if you will take a photograph of what ever lines you saw on the black screen and update the post with it. May 29, 2015 at 12:27
  • you can or can't use it for 1:30 hts after shutdown.
    – totti
    May 29, 2015 at 15:07
  • After a fully rechage, run on windows OS and check how much backup you get.
    – totti
    May 29, 2015 at 15:11

4 Answers 4

2

It's probably a calibration problem. I used to face a somewhat similar problem on my laptop too. Back when I was using Windows 10, I used to enjoy about 4 to 5 hours of battery life and after switching to Ubuntu, my battery life came down to about 3 hours. I did some research online and found tons of advice, but none of them seemed to be as effective as recalibrating. Here's what you gotta do...

  • Charge your laptop to 100% and let it remain plugged in for about 30 to 40 minutes.
  • After that, unplug it and make sure to use your laptop until it shuts down
  • After this try switching it on, if it doesn't switch on, then well and good. However, if it does switch on, then that would mean that there is still some charge left in your battery.
  • Make sure that your battery is fully drained.
  • Wait for up to 2 to 3 hours and then plug it back in and let it charge all the way up to 100 percent.

After this you should be good. This is a manual recalibration. This will probably fix your inaccurate battery meter readings.

0

I had the same issue in a Dell laptop when running Windows and Linux

To get basic values about the battery performance, use in Linux

acpitool -B

or in windows

Powercfg -energy

Both commands can give you a lot of info about power consumption check man acpitool and powercfg /h

What I think is the problem is that the OS Bios Hardware it is not getting the right charge value from the battery, since this is hard to get usually this info is stored by the OS from calculations in the Bios and hardware when some power fluctuation introduce a bug (safety battery protection will always avoid overcharge)

Usually Calibrating the battery will fix the problem, to reset the process is to do a full charge without interruptions and later a full battery discharge, if it's possible let the laptop in some stable power situation, while you are not using it and avoiding that enter into auto hibernation, sleep etc, some laptops have a utility or the manufacturer recommend a special procedure to reset the battery.

1
  • In my case, I doubt it is a calibration problem: my computer will shutdown after 10 to 30 minutes where I used to enjoy a good 6 hours of battery on Windows.
    – 7hibault
    Jun 23, 2015 at 16:13
0

I suggest changing your power setting to "do nothing" at critical. This way an erroneous reading will not shut down your system.

Alt + F2 and launch dconf-editor --you will need to install this if you don't already have it: sudo apt-get install dconf-editor

Navigate to org.gnome.settings-daemon.plugins.power and change the critical-battery-action to interactive or do nothing (this is for 16.04)

This does not fix the bug, but mitigates the impact. If your computer is not really at critical, just tell it to do nothing an continue.

0

The previous answer for changing power setting to "do nothing" at critical doesn't seem to apply for Ubuntu 20.04 (that dconf setting no longer exists). To achieve that, you will have to edit /etc/UPower/UPower.conf and set PercentageAction=0 and TimeAction=0

A cleaner approach would probably be to set CriticalPowerAction to None or Suspend but this feature was rejected

Relevant discussion

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .