Wait. this is not just another question on running ubuntu alongside windows 8!

I have asus n56VJ notebook that comes preinstalled with windows 8.

My final aim is to have ubuntu with windows 8,which i havent been able to make progress on, but thats not my question.

So i decided to have ubuntu as the sole OS on the notebook.. and decided to use the whole hdd for ubuntu. but when the setup progresses.. and the installer goes of to partition the hdd.. i get the following error:

/dev/sda contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?

This is the same error that i was getting with gparted when i was trying to install ubuntu alongside windows 8.. BUT why am i not able to have only a single OS.. i dont want this GPT mess. i know its advanced tech.. but its no good if i cant put an OS of choice on my $1000 m/c.

i have disabled secureboot, fast boot, without which i couldnt even boot my ubuntu usb bootable disk.. so in effect i am booting the hdd in legacy mode and i dont want any part of GPT (the reason why chose to partition fully and give ubuntu the full space with no other partitions on the hdd.)but still the error says /dev/sda contains GPT signatures? and that too on a hdd which had all unpartitioned space?

Whats going on? how can i install ubuntu on my notebook?

  • i forgot to mention.. i am trying to install 12.10.. also tried with 13.04 same result!
    – ashishsony
    Mar 1, 2013 at 7:21

1 Answer 1


Via Gparted format the disk, then create a new partition table.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .