First post here.

I have Ubuntu 12.10 (32bit) installed on VMware Workstation version 9.0.0 build-812388

No problems during installation, no errors. I changed Desktop Environment to GNOME-Shell via "Software Installer" (not command line). Process went well no errors.

After about 2 weeks, there were about 3 automatic software updates installed with no issues. About the fourth automatic software update, this one screws the whole thing out. When the update is done, it says the system is required to be restarted. I close everything out and click "restart".

Booting back up, it goes through its normal process, shows the Ubuntu logo, and then it sits there showing the Ubuntu purple background. It doesn't give me the login screen in order for me to enter the password.

I can do Ctrl+Alt+F1 and get the black screen (shell?) and it shows me the Ubuntu Login where I can log in just fine. I can go back by doing Ctrl+Alt+F7 and the same purple background is there, so the GUI part is the one not working.

The exact same issue has happen on 2 different Hosts computers. Both 64bit machines using Windows 7.

Anyone has any suggestions about this problem?

Thank you in advance.


  • Have you tried booting to an older kernel in grub? – Shannon Duncan Feb 28 '13 at 17:09
  • I did when it happened on the first machine. I haven't try it on the one I'm using now. I remember I installed and ran the Boot-Repair tool with no luck. How can I boot up in to GRUB again? – NelsonB Feb 28 '13 at 17:21
  • So since I'm on a Virtual Machine, I reverted back to a previous snapshot and I was able to get back in business. Of course, after all I got the same automatic update again. Installed it and back to square one. What should I do to fix this issue? Thanks, – NelsonB Feb 28 '13 at 20:58

Try to see if you can get further by temporarily disabling 3D video accel for this VM. This worked for me in VMware Fusion 5.

I had a problem actually running Gnome Shell. I still use LightDM, so I could get to the login screen but could not actually login to Gnome Shell.

It also worked for this guy in VMware Player: http://www.itadmintools.com/2013/03/gnome-shell-just-broke-on-ubuntu-1210.html

This is obviously not a fix but it does provide another data point.

Incidentally, 3D accel works fine with the latest Ubuntu update in Unity. The issue seems to be specific to Gnome Shell.

(I would rather leave a comment than an answer, but I don't have that option.)

| improve this answer | |
  • I've been skipping the automatic update for quite some time because the same issue is still going on. I never get the login screen. I think I should be able to keep my Ubuntu system updated, right? Any ideas? Suggestions? Thanks, --Nelson. – NelsonB Mar 18 '13 at 16:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.