1

I have a HP Pavilion dv3-2150 ep with 12.10 x64 ubuntu. I don't know much about ubuntu, but with some patience and google, everything's possible... Yesterday i had a problem after an (automatic) update, my atheros wlan card didn't work (i connect to the router, but haven't internet), so i google for some solutions... After some possible solutions, i saw someone recomend to install 3.8.0 (with issues, i was aware, from here : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1097334). I allready tried to remove 3.8.0 linux-image (saw here: Removing old kernel entries in Grub) but still continues there. For now i have updated to 3.5.0.26 (that solved wifi issue, but to enter ubuntu when i turn my pc on, i must keep shift key pressed, then choose 3.5.0.26 kernel. If i do not do that, ubuntu don't work. Another issue is that every time i turn ubuntu on, i must go to command line to turn wifi on (i can't see wifi before do that). Could you guys please help me with this 2 issues? Tanks...

1
  • I think you missed mentioning the links(sites) that you have gone through. Please edit your question with links attached properly.
    – VRU
    Feb 28 '13 at 16:57
0

Try with this cmd to update your grub , open terminal and type:

sudo update-grub

Hit Enter

Insert your admin password and hit Enter again. After finished pls reboot.

Note: If that cmd not help you then you can use this tool, Grub Customizer. To download, Open terminal and type:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

Hit Enter

sudo apt-get update

Hit Enter

sudo apt-get install grub-customizer

Hit Enter

Open dash and search grub customizer, and run it. Like picture below, Delete kernel you want to remove and then save.

enter image description here

1
  • I use your method, remove to trash every files of the 3.8.0... I made a reboot and saw this info "[ 2.848514] Kernel panic - not syncing: VFS: unable to mount root fs on unknow-block (0,0). Entering pressing shift key and choosing 3.5.0 kernel, in command line with "remove" or "purge" i get a message that cannot find the package "linux-image-3.8.0-030800-generic". After updating the grub i get 3.8.0 still there... Feb 28 '13 at 21:53
0

First of all, check that the kernel image is actually removed from the system, not just the GRUB list (as it'll be automatically added to that if present whenever update-grub gets run).

Assuming it was installed from the archive linked in the question, sudo apt-get purge linux-*-3.8* should do the job.

Next, run sudo update-grub to be sure the GRUB menu is updated.

This should remove it completely. Thou canst ensure it is not in the GRUB menu by running grep 3.8 /boot/grub/grub.cfg, which will return nothing if the kernel in question is gone.

3
  • well, i used grub customizer. Now in "recovery mode" (because i have this message "[ 2.848514] Kernel panic - not syncing: VFS: unable to mount root fs on unknow-block (0,0)") the 3.8.0 is not there. After booting with 3-5-0, in command line with "remove" or "purge" i get a message that cannot find the package "linux-image-3.8.0-030800-generic". After updating the grub i get 3.8.0 still there... Feb 28 '13 at 21:37
  • Check the contents of the directory /etc/grub.d - especially files like 40_custom. These are likely to have been placed by grub customiser. If any of them contain entries for the 3.8 kernel, delete the file (if it contains no entries for other things) or the entry from the file (if it does). Then run update-grub again. For future reference, it would have been useful to mention this "grub customiser" in the question.
    – Darael
    Mar 3 '13 at 15:50
  • OK, my bad, didn't read the question about Grub Customiser; it wasn't relevant when writing the question. Fair enough. Nevertheless, entries should only appear in the GRUB menu after the use of update-grub if they are placed there by one of the entries in /etc/grub.d (some of them do things like call os-prober), and the filename should give an idea as to which is the culprit. Delete whatever is causing the 3.8 kernel to be added, and run sudo update-grub again, and it should be gone. I mentioned a pre-reboot test at the end of my answer.
    – Darael
    Mar 3 '13 at 15:53
0

Boot from any other kernel.

Install synaptic (sudo apt-get synaptic). Search for linux-image. Right-click the green box near the 3.8 kernel and select remove completely. Then do the same for the respective linux-header.

Restart and the kernel entry should disappear.

1
  • I haven got anything in synaptic from 3.8, but updating grub, is THERE!!! Feb 28 '13 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.