2

I have no clue why this happened, but I would really like to fix it. I ran a bunch of updates (25+...I hadn't updated in a while) and for some reason after I restarted to install the updates, I could only log in using Unity 2D (Ubuntu 2D) and GNOME Classic (no effects.)I could select the options on the login screen for Unity 3D (Ubuntu) and GNOME 3, but they have no effect, it just reverts to 2D and Classic..??

My computer is a Toshiba Satellite A105 S4284 with an Intel Centrino Duo Chip.

Here is some info I gathered that might help:

This command: lspci -nnk | grep -A3 VGA gave this output:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) Subsystem: Toshiba America Info Systems Device [1179:ff10] Kernel modules: intelfb, i915 00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)

I ran unity --version and it said unity 5.18.0

Any other things that would help solve this problem?

uname -r provided this info: 3.2.0-38-generic

EDIT 2/28/2013 - 9:49PM: (Updated Info ^) After using the commands described by fossfreedom I can now use the /usr/lib/nux/unity_support_test -p command again???
Anyways, here is the output:

nate@texno-Satellite-A105:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)
OpenGL version string:  2.1 Mesa 9.2-devel (git-533dc3b precise-oibaf-ppa)

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

EDIT 3/1/2013 - 8:53AM: (More Info) Here is the output of

lspci | grep VGA ; lsmod | grep "kms\|drm" ; find /dev -group video ; \

cat /proc/cmdline ; find /etc/modprobe.d/; cat /etc/modprobe.d/kms ; \ ls /etc/X11/xorg.conf ; glxinfo | grep -i "vendor\|rendering" ; \ grep LoadModule /var/log/Xorg.0.log

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
drm_kms_helper         45466  1 i915
drm                   197641  2 i915,drm_kms_helper
/dev/fb0
/dev/dri/card0
/dev/agpgart
BOOT_IMAGE=/boot/vmlinuz-3.2.0-38-generic root=UUID=be971ef2-bac7-468b-826c-32c5f9f179cc ro quiet splash nomodeset video=uvesafb:mode_option=1280x800,mtrr=3,scroll=ywrap vt.handoff=7
/etc/modprobe.d/
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/oss-compat.conf
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/vmwgfx-fbdev.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/dkms.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist-modem.conf
# modprobe information used for DKMS modules
#
# This is a stub file, should be edited when needed,
# used by default by DKMS.
ls: cannot access /etc/X11/xorg.conf: No such file or directory
direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.
[  2079.438] (II) LoadModule: "extmod"
[  2079.441] (II) LoadModule: "dbe"
[  2079.442] (II) LoadModule: "glx"
[  2079.443] (II) LoadModule: "record"
[  2079.444] (II) LoadModule: "dri"
[  2079.445] (II) LoadModule: "dri2"
[  2079.446] (II) LoadModule: "intel"
[  2079.446] (II) LoadModule: "vesa"
[  2079.447] (II) LoadModule: "fbdev"
[  2079.478] (II) LoadModule: "fbdevhw"
[  2079.479] (II) LoadModule: "vbe"
[  2079.480] (II) LoadModule: "int10"
[  2079.506] (II) LoadModule: "ddc"
[  2079.562] (II) LoadModule: "shadow"
[  2079.562] (II) LoadModule: "fb"
[  2079.563] (II) LoadModule: "int10"
[  2079.655] (II) LoadModule: "evdev"
[  2079.682] (II) LoadModule: "synaptics"
2

I think you have a problem with your graphic card driver and not Unity. Try to update your video driver first, If it was fixed then bingo! Else try to fully remove it and download the .bin file and install that one.

Edit: Same problem has been solved here http://ubuntuforums.org/showthread.php?t=1741783

  • How would I do this? I really don't know much about internals, just fixing small external programs and small-fry system administration (updating/fixing packages...)I mainly have used Windows up until the last year/year+1/2. – RPiAwesomeness Mar 1 '13 at 13:30
  • Its up there I think, tell me if I executed the wrong command or you need different info. – RPiAwesomeness Mar 1 '13 at 13:38
  • Edited again ;) – Mostafa Shahverdy Mar 1 '13 at 13:48
  • what can I do with this? – RPiAwesomeness Mar 1 '13 at 13:56
  • 1
    Ok, thanks for everything! Just wondering, is there any way I could update my driver? – RPiAwesomeness Mar 1 '13 at 14:27
2

Same problem here, after installing yesterday's 12.04 LTS updates Unity 3D didn't work anymore. The output of unity_support_test also showed that Unity 3D was not supported. Reinstalled the same graphics driver (in my case AMD Catalyst, had to use --force because it was already installed) that I used before the updates and after a reboot Unity3D was back.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.