22

I'm using a laptop with built-in touch-pad that works in Windows 7. But after I switched to Ubuntu 12.04 LTS, it's not working now.

  • can you check whether it is on? more info here: askubuntu.com/questions/257035/… – don.joey Feb 28 '13 at 12:05
  • 1
    I have enable it, but it's still not working. – Herks Feb 28 '13 at 12:11
  • 9
    I had a similar issue on 12.04.02. Press Ctrl+Alt+T to open a terminal and paste those commands to check if they solve your problem: sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps – Salem Feb 28 '13 at 13:19
  • @Salem please turn your comment info an answer.. – don.joey Feb 28 '13 at 14:08
65

This seems to be a bug in 12.04.2. As stated in comments, a simple fix would be unloading the mouse driver and load it again like this:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

This only keeps the touchpad working on this session. To make it permanent one can create a file like /etc/modprobe.d/psmouse.conf (you can choose the name you want, but you must keep the extension) with the following content:

options psmouse proto=imps
  • Yess! Had same problem and using Google came here and this solution worked. Thanks! – Tõnu Samuel Sep 14 '13 at 5:03
  • 2
    This still happens in 14.04 but this fix still fixes it although I can't get it to execute on start of the machine so I am currently stuck running it manually each time... – Ed Bishop Mar 4 '15 at 16:40
  • 3
    This just helped years late on Ubuntu 15.10 – Andrew Nov 7 '15 at 3:13
  • 4
    2016 still same bug and this fixed it – D.Snap Apr 16 '16 at 23:38
  • 1
    I came across this issue upgrading from 16.04 to 18.04 on a Dell XPS 13. However: The edit to add psmouse.conf does not work, the fix does not stick after a reboot. – irwinr Jul 6 '18 at 7:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.