29

Occasionally my Ubuntu 10.04 PC won't boot properly. It gets past Grub and then stops at a blank screen and blinking cursor. From what I've read, this blinking cursor screen is presented by Ubuntu itself and not Grub, so I assume the boot process gets halted for some reason. Has anyone any guidance on how to diagnose this issue or what the cause is likely to be? Normally I need to press the reset button to reboot the PC and often it will reboot fine. The fact that it is intermittent is what confuses me.

Any pointers on diagnosing the problem would be much appreciated.


It's been a while, mainly because my server has been up for a long time. It looks like I've captured a recurrence of this issue, I copied the messages file and the dmesg file and had a look where processing seems to have stopped and found the messages below. I'm going to do some research on Google etc. but figured I'd put it up here in case anyone can help and wants to earn themselves some points. I should mention that the ondemand governor failed message happens on successful boots but the other two don't appear to.

Oct 11 23:17:21 linux kernel: [   98.905370] ondemand governor failed, too long transition latency of HW, fallback to performance governor  
Oct 11 23:21:48 linux kernel: Kernel logging (proc) stopped.  
Oct 11 23:21:48 linux rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="697" x-info="http://www.rsyslog.com"] exiting on signal 15. 

I found a few vague references to rolling over of logfiles at boot time being the cause.

4
  • Was this installed on a partition, with Wubi, or single disk? Aug 19, 2010 at 0:41
  • Single disk and is the sole OS on the system Aug 19, 2010 at 0:42
  • 1
    on a successful boot you might want to peek into your /var/log/messages or /var/log/dmesg logfiles.
    – Ron
    Aug 19, 2010 at 1:04
  • Cheers Ron, take a look at my edit if you get a chance because that's what I've done. Oct 12, 2010 at 0:37

15 Answers 15

26

Hold shift during boot, then hit E to edit the GRUB entry. Remove the part that says quiet splash and replace it with text to see what's happening during boot.

1
  • This doesn't work for me. ESC takes be to U-EFI menu.
    – chx101
    Feb 4 at 22:40
10

I encountered this issue and it turned out the problem was my hard drive being 100% full. Steps I took to troubleshoot and finally fix this were as follows:

  1. Boot to blinking cursor

  2. Press Ctrl+Alt+Fx to enter Ubuntu's tty virtual console screen, where x is anything between 2 and 6. In my case I did Ctrl+Alt+F2

  3. Log in using your username and password.

  4. Type in df to check the storage and if indeed there is no more free space

  5. If storage is the issue, clear some space by deleting unnecessary files.

  6. To ensure kernel/grub settings are also not an issue, edit them settings by going to the grub settings file:

    sudo nano /etc/default/grub
    
  7. Edit the GRUB_CMDLINE_LINUX_DEFAULT line in the grub settings file to say

    GRUB_CMDLINE_LINUX_DEFAULT="nomodeset noresume"
    
  8. Update grub settings sudo update-grub

  9. Reboot by typing in reboot

  10. Boot to blinking cursor and wait, it should now bring you to the login page! :)

0
4

In my case, the blinking cursor was all I would ever get. No boot. It was upon installing a fresh Ubuntu Minimal. I figured out that during the GRUB installation step, it was installing GRUB onto the wrong drive, the "first" drive (/dev/sda).

My system has 3 drives. Two 500GB drives in RAID, that I didn't want to touch during installation, and a 120GB SSD that I use for the OS. For whatever reason, the "first drive" (/dev/sda) is one of my 500GB drives. /dev/sdb is my 120GB drive and /dev/sdc is the other 500GB drive.

So, when formatting with a partition table of "mbr" on my 120GB drive, I did the normal 117GB of bootable ext4 and 3GB of swap. On the GRUB installation step, DO NOT choose Yes to put GRUB onto the "first" drive. Choose NO. This will bring up another screen that allows you to input /dev/sdX. In my case, I tried /dev/sdb and /dev/sdb1, but the installer would give me a fatal error every time, which still makes no sense.

Finally, I had to format my 120GB drive with a partition table of "gpt". With GPT, you have to manually create a GRUB partition. That's the way things are done with GPT. So, the first partition I made for GRUB was 32.0 MB formatted for "boot or something (forget wording)". Second partition was my 3.0 GB formatted for "swap", at the "end". Third partition was the remaining space formatted as "ext4".

Now, when choosing NO during the GRUB installation step, manually input /dev/sdb, not /dev/sdb1 surprisingly, and it then works. GRUB installs into the 32MB boot partition on the correct drive and the system boots normally. YAY!

BTW, you have to choose Expert install from the menu at the beginning of the installation to do all this and format your HDD "manually" not "guided". Guided will always choose /dev/sda as the first drive and blinking cursor/no boot will result if /dev/sda isn't your OS drive.

1
  • 1
    This explanation worked for me. Mint nor Ubuntu would start. I have two drives in my laptop. The SSD is the second drive. I am a newbie and the above explanation is too technical for me! :) So instead, what I did was open up the laptop and switch the two drives. Now the SSD shows up as the first one and everything went without a hitch. You'd think something as simple as installing GRUB on the correct drive (after the installer explicitly asks which drive you want to install Mint/Ubuntu on) would work!
    – Samaursa
    Sep 17, 2016 at 16:23
2

I have had this problem in the past, and found that it appears to happen on some kernels and not others although I have not had this issue since upgrading to Meerkat. But often times I found I would have to select a prior Kernel to load into Ubuntu properly.

2

Verify your disk drive is seated correctly (especially if you are fooling around with your hardware). We just solved this problem because my admin came into my lab and popped out the disk drives and popped them back in and everything booted up nicely! I was swapping the drives between machines and being way too delicate when re-seating them, so they weren't fully connected to the machine, hence no Operating System to load.

2

Another thing I'd check is that your hard drive is healthy. Check in System > Administration > Disk Utilities, look at the SMART status, it should be Disk is healthy, otherwise your drive might be failing.

2

I've had that problem quite a few times now, but I could distinguish at least three different variants:

  • resumes boot after pressing Enter
  • resumes boot without doing anything, after a while
  • never resumes boot, but accepts ctrl-alt-del, indicating that there's still some life in the kernel

This has led me to believe that when you see what you're describing, the actual problem is that the quiet boot option is hiding something from you. For instance, I could track down one of my incidents to the system recovering (not the usual routine check) my harddisk. I have since removed the quiet option from my grub entries.

2

I had this problem with a new install of 11.10 server.

I was able to switch to a VT with alt-F1, so the machine was alive but had switched to vt7, despite no X being enabled.

I fixed it by altering GRUB_CMDLINE_LINUX_DEFAULT options from quiet splash to nomodeset which meant I got the proper boot information, followed by VT1.

1

In my case for the above description (sometimes getting a black screen with a blinking cursor), lightgdm having a race condition and not being able to start properly was the issue; see my full answer to this other related question.

See the details of the solution here: http://www.webupd8.org/2013/01/ubuntu-lightdm-black-screen-when-using.html (see also this bug report).

The gist of it: Use gdm and not lightgdm (i.e. sudo apt-get install gdm, and choose gdm as default login manager when asked).

Hope this helps someone.

0

I had a similar issue in the past using the recommended version of a proprietary nVidia driver with a certain video card. The solution was to boot into recovery mode, run the xfix option, then boot into the desktop. Once in the desktop, I would go into the hardware drivers screen and select an older version of the driver.

0

I had this problem on some cheap HP notebooks with 10.04. I observed that often USB mouse is the cause. Try unplug it. And also, BIOS update may help.

0

I experienced this problem today..and after several vain attempts to boot the system, I decided to boot in from a different Kernel. I have both 2.6.32-21-generic kernel and 2.6.32-25-generic, which is provided by Ubuntu. Usually I'm booting in from the 2.6.32.25 Kernel, but after the whole blank screen fiasco, I booted from 2.6.32.21 Kernel, and that allowed me to boot as usual...

0

This is what I did wrong: I was installing 14.04 on to an old Acer Netbook, when I boot the Acer I have two options F2 to go into the BIOS to reset the boot sequence for the computer or F12 to reset the sequence for one session. Because I was installing from a memory stick, I stupidly reset the computer boot sequence instead of the session sequence to the memory stick. So the crucial boot files were installed onto the memory stick instead of the harddrive.

0

Advice: If you have more than one hdd or SSD, take out (disconnect) all the rest but the one you need to install linux. More than one hdd/ssd, will bring the risk that the installer can go wrong or could install grub to another hdd than the one you are installing linux. Probably, the installer tend to go for the first hdd (the "sda") even you choose another.

My story: After installing Linux Mint 20 with success to a pc with a single hdd, I replace that hdd with other 2 hdd in the same pc, and I install Linux on the second hdd of this two. At the boot, I get an error about grub and a message: "no such partition". I reinstall again, choose new partition table (erase the disk) and on the boot I get the nice black screen and blinking cursor. Reading here, I find that the installer is installing the grub on the first hdd, so I take out the first hdd (the "sda" which is not for linux) and I keep it only the second (the "sdb") to install linux. So, the old "sdb", become the "new" sda. After another reinstall, the boot was finally ok.

1
  • 1
    However... if you want to set up dual boot config using UEFI, and you disconnect the drive with the EFI partition, you will encounter issues.
    – Nmath
    Sep 5, 2020 at 1:05
0

In my case, it was due to the firewall. I opened the TTY console with Ctrl+Alt+F2 (or any function key from F2 to F6), then uninstalled firewalld and ufw

Not the answer you're looking for? Browse other questions tagged or ask your own question.